• POJ 1045:Bode Plot


    Bode Plot
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 13392   Accepted: 8462

    Description

    Consider the AC circuit below. We will assume that the circuit is in steady-state. Thus, the voltage at nodes 1 and 2 are given by v1 = VS coswt and v2 = VRcos (wt + q ) where VS is the voltage of the source,w is the frequency (in radians per second), and t is time. VR is the magnitude of the voltage drop across the resistor, and q is its phase. 

    You are to write a program to determine VR for different values of w. You will need two laws of electricity to solve this problem. The first is Ohm's Law, which states v2 = iR where i is the current in the circuit, oriented clockwise. The second is i = C d/dt (v1-v2) which relates the current to the voltage on either side of the capacitor. "d/dt"indicates the derivative with respect to t. 

    Input

    The input will consist of one or more lines. The first line contains three real numbers and a non-negative integer. The real numbers are VS, R, and C, in that order. The integer, n, is the number of test cases. The following n lines of the input will have one real number per line. Each of these numbers is the angular frequency, w

    Output

    For each angular frequency in the input you are to output its corresponding VR on a single line. Each VR value output should be rounded to three digits after the decimal point.

    Sample Input

    1.0 1.0 1.0 9
    0.01
    0.031623
    0.1
    0.31623
    1.0
    3.1623
    10.0
    31.623
    100.0

    Sample Output

    0.010
    0.032
    0.100
    0.302
    0.707
    0.953
    0.995
    1.000
    1.000

    水题,公式推导。话说真不能再总纠结这水题了,越做越水了现在。

     v1 = VS

    v2 = VRcos (wt + q ) 

     v2 = iR

    C=d/dt (v1-v2) 即(v1-v2) 对t求导

    已知Vs,C,R,w,求 VR。因为任意的t,等式都成立,所以对t取特殊值,解方程即可。

    代码:

    #include <iostream>
    #include <cmath>
    #include <algorithm>
    using namespace std;
    
    int main()
    {
    	double Vs,R,C,w;
    	int n,i;
    	cin>>Vs>>R>>C>>n;
    
    	for(i=1;i<=n;i++)
    	{
    		cin>>w;
    		printf("%.3f",sqrt(1.0/(1+C*C*w*w*R*R))*C*w*R*Vs);
    		cout<<endl;
    	}
        return 0;
    }


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    JQuery常用动画实现函数
    DOM对象和JQuery对象进行转换
    JQuery中的mouseover和mouseenter的区别
    JQuery使用和选择器
    LintCode 11 二叉查找树的搜索区间
    Java IO整理
    JS基础知识——缓动动画
    JS——无缝滚动
    Java GC系列(1):Java垃圾回收简介
    深入理解Java之线程池
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785858.html
Copyright © 2020-2023  润新知