• POJ 2521:How much did the businessman lose


    How much did the businessman lose
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 9965   Accepted: 6749

    Description

    Businessmen, of course, can make much money. However, sometimes, they would lose money in trading. For example, Jame, a businessman, brought in some goods each cost him 40 yuan and he decided to sell at the price of 70 yuan. Then a customer came to buy one, gave Jame 100 yuan, and of course got back 30 yuan. You may said, "Jame earned 30 yuan." But unfortunately, Jame found the 100 yuan from the customer was fake. What a poor man! In this case Jame lost 70 yuan (40 (the goods price) + 30 (the money paid back to the customer)). 

    Now your task is to calculate how much Jame would lose in this kind of trade. Of course in this case, sometimes Jame may still earn. 

    Input

    The input consists of several instances. Each instance contains four integers N, M, P and C, which are all in the range [0, 50000], separated by a single space. 

    N is the cost price of Jame good. 
    M is the sell price. 
    P is the total fake money the customer gave Jame. 
    C is how much Jame paid back to the customer. 

    Here N < M. And P may be less than M, as customer may pay with some fake money and some true money. 

    The input is terminated by a line containing 4 zeros. 

    Output

    For one instance, output one line contains exactly one integer, which tells how much Jame lost in the trade. If Jame still earned, just output a negative integer, the absolute value of which tells the money Jame earned.

    Sample Input

    40 70 100 30
    40 70 50 20
    14604 32391 3902 153
    0 0 0 0
    

    Sample Output

    70
    20
    -13885

    水题,商贩花N元买了一个商品,卖M元,买的人给了商贩P元的假币,C是商贩找回给买家的真钞。

    问整个过程中商贩赔了多少钱。

    赔的钱=N-(M-P+C)+C=N-M+P

    代码:。。。

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    using namespace std;
    
    int main()
    {
    	int n,m,p,c;
    	while(cin>>n>>m>>p>>c && n+m+p+c)
    	{
    		cout<<n-m+p<<endl;
    	}
    	return 0;
    }




    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    软件工程之开发过程
    软件工程设计之四则运算
    Android笔记-5-EditText密码和Checkbox二选一
    Android笔记-4-实现登陆页面并跳转和简单的注册页面
    Android笔记-3-EditText的属性介绍
    Android笔记-2-TextView的属性详解
    Android笔记-1
    Microsoft Build 2015
    网络受限是个什么东东?
    几乎所有编程语言的hello, world程序(3)
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785849.html
Copyright © 2020-2023  润新知