• POJ 1164:The Castle


    The Castle
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 6677   Accepted: 3767

    Description

         1   2   3   4   5   6   7  
    
       #############################
    
     1 #   |   #   |   #   |   |   #
    
       #####---#####---#---#####---#
    
     2 #   #   |   #   #   #   #   #
    
       #---#####---#####---#####---#
    
     3 #   |   |   #   #   #   #   #
    
       #---#########---#####---#---#
    
     4 #   #   |   |   |   |   #   #
    
       #############################
    
    (Figure 1)
    
    
    
    #  = Wall   
    
    |  = No wall
    
    -  = No wall

    Figure 1 shows the map of a castle.Write a program that calculates 
    1. how many rooms the castle has 
    2. how big the largest room is 
    The castle is divided into m * n (m<=50, n<=50) square modules. Each such module can have between zero and four walls. 

    Input

    Your program is to read from standard input. The first line contains the number of modules in the north-south direction and the number of modules in the east-west direction. In the following lines each module is described by a number (0 <= p <= 15). This number is the sum of: 1 (= wall to the west), 2 (= wall to the north), 4 (= wall to the east), 8 (= wall to the south). Inner walls are defined twice; a wall to the south in module 1,1 is also indicated as a wall to the north in module 2,1. The castle always has at least two rooms.

    Output

    Your program is to write to standard output: First the number of rooms, then the area of the largest room (counted in modules).

    Sample Input

    4
    7
    11 6 11 6 3 10 6
    7 9 6 13 5 15 5
    1 10 12 7 13 7 5
    13 11 10 8 10 12 13

    Sample Output

    5
    9

    题意是一个城堡分成了m*n个块,然后给出了每个块一个数字,这个数字代表门的情况,如果这个块西面有门,那么1就要加到这个数字中。如果这个块北面有门,那么2就要加到这个数字中。如果这个块东面有门,那么4就要加到这个数字中。如果这个块南面有门,那么8就加到这个数字中。

    所以就可以使用这个数&1 &2 &4 &8来判断哪一个方向有门,连通着的算一个房间,要求的是房间的数量和最大房间的块数。

    应该算是深度搜索的模板题了吧。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    int row,col,i,j,sum,result1,result2;
    int value[70][70];
    int color[70][70];
    
    int move_x[5]={1,0,-1,0};
    int move_y[5]={0,1,0,-1};
    
    void dfs(int a,int b)
    {
    	color[a][b]=1;
    	sum++;
    	int a_x,b_x;
    
    	if((value[a][b]&1)==0)
    	{
    		a_x=a+move_x[3];
    		b_x=b+move_y[3];
    		if(a>=1 && a<=row && b>=1 && b<=col && color[a_x][b_x]==0)
    		{
    			dfs(a_x,b_x);
    		}
    	}
    	if((value[a][b]&2)==0)
    	{
    		a_x=a+move_x[2];
    		b_x=b+move_y[2];
    		if(a>=1 && a<=row && b>=1 && b<=col && color[a_x][b_x]==0)
    		{
    			dfs(a_x,b_x);
    		}
    	}
    	if((value[a][b]&4)==0)
    	{
    		a_x=a+move_x[1];
    		b_x=b+move_y[1];
    		if(a>=1 && a<=row && b>=1 && b<=col && color[a_x][b_x]==0)
    		{
    			dfs(a_x,b_x);
    		}
    	}
    	if((value[a][b]&8)==0)
    	{
    		a_x=a+move_x[0];
    		b_x=b+move_y[0];
    		if(a>=1 && a<=row && b>=1 && b<=col && color[a_x][b_x]==0)
    		{
    			dfs(a_x,b_x);
    		}
    	}
    
    }
    
    int main()
    {
    	memset(color,0,sizeof(color));
    
    	cin>>row>>col;
    	for(i=1;i<=row;i++)
    	{
    		for(j=1;j<=col;j++)
    		{
    			cin>>value[i][j];
    		}
    	}
    	result1=0;
    	result2=0;
    	for(i=1;i<=row;i++)
    	{
    		for(j=1;j<=col;j++)
    		{
    			sum=0;
    			if(color[i][j]==0)
    			{
    				dfs(i,j);
    				result2++;
    			}
    			result1=max(sum,result1);
    		}
    	}
    
    	cout<<result2<<endl;
    	cout<<result1<<endl;
    	return 0;
    }
    



    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    使用gitblit搭建一个简单的局域网服务器
    Git的一些基本操作和命令
    oracle 常用函数
    Windows 下用 gogs 配置局域网 git server
    慎用 new、delete
    探究functools模块wraps装饰器的用途
    处理QMenu的triggered信号时遇到的一个问题
    浅析MySQL中exists与in的使用
    java-工具类-读取配置文件
    Java web的基本概念
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785819.html
Copyright © 2020-2023  润新知