• POJ 1035:Spell checker


    Spell checker
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 22574   Accepted: 8231

    Description

    You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
    If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
    ?deleting of one letter from the word; 
    ?replacing of one letter in the word with an arbitrary letter; 
    ?inserting of one arbitrary letter into the word. 
    Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

    Input

    The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
    The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
    All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

    Output

    Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

    Sample Input

    i
    is
    has
    have
    be
    my
    more
    contest
    me
    too
    if
    award
    #
    me
    aware
    m
    contest
    hav
    oo
    or
    i
    fi
    mre
    #

    Sample Output

    me is correct
    aware: award
    m: i my me
    contest is correct
    hav: has have
    oo: too
    or:
    i is correct
    fi: i
    mre: more me

    题意是给你一个已知的字典,然后给你一个一个字符串,让你批改字符串,可能的情况是

    1完全正确

    2修改了一个字符

    3增加了一个字符

    4删除了一个字符

    输出得到的结果。

    简单题,对于字符串的枚举,就看其长度等于,大于1,小于1,之后比较相等的字符数量即可,符合的输出。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    vector<string>dic;
    vector<string>modi;
    
    void solve(string test)
    {
    	modi.clear();
    	int i;
    	int len=dic.size();
    
    	for(i=0;i<len;i++)
    	{
    		if(dic[i]==test)
    		{
    			cout<<test<<" is correct"<<endl;
    			return;
    		}
    		if(dic[i].length()==test.length())
    		{
    			int result=0,j;
    			for(j=0;j<test.length();j++)
    			{
    				if(dic[i][j]==test[j])
    					result++;
    			}
    			if(result==test.length()-1)
    			{
    				modi.push_back(dic[i]);
    			}
    		}
    		else if(dic[i].length()+1==test.length())
    		{
    			int result=0,j=0,k=0;
    			for(j=0;j<dic[i].length()&&k<test.length();k++)
    			{
    				if(dic[i][j]==test[k])
    				{
    					result++;
    					j++;
    				}
    			}
    			if(result==dic[i].length())
    			{
    				modi.push_back(dic[i]);
    			}
    		}
    		else if(dic[i].length()-1==test.length())
    		{
    			int result=0,j=0,k=0;
    			for(k=0;k<test.length()&&j<dic[i].length();j++)
    			{
    				if(dic[i][j]==test[k])
    				{
    					result++;
    					k++;
    				}
    			}
    			if(result==test.length())
    			{
    				modi.push_back(dic[i]);
    			}
    		}
    	}
    
    	if(modi.size())
    	{
    		cout<<test<<":";
    		for(i=0;i<modi.size();i++)
    		{
    			cout<<" "<<modi[i];
    		}
    		cout<<endl;
    	}
    	else
    		cout<<test<<":"<<endl;
    }
    
    int main()
    {
    	string test;
    	dic.clear();
    	while(cin>>test)
    	{
    		if(test=="#")
    			break;
    		dic.push_back(test);
    	}
    	while(cin>>test)
    	{
    		if(test=="#")
    			break;
    		solve(test);
    	}
    	return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    poj 1321
    Cocos2D-html5 公布游戏js编译为jsc
    Android定位开发之百度定位、高德定位、腾讯定位,三足鼎立一起为我所用!
    python 设计模式之 单例模式
    css画电脑键盘
    【C/C++学院】(23)Mysql数据库编程--C语言编程实现mysqlclient
    用DOM4J包实现对xml文件按属性分离。
    MVC4中AJAX Html页面打开调用后台方法实现动态载入数据库中的数据
    贝勒爷教你怎样在Mac上安装Microsoft Office
    6.Swift教程翻译系列——Swift集合类型
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785814.html
Copyright © 2020-2023  润新知