• POJ 1519:Digital Roots


    Digital Roots
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 25766   Accepted: 8621

    Description

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit. 

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

    Input

    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

    Output

    For each integer in the input, output its digital root on a separate line of the output.

    Sample Input

    24
    39
    0

    Sample Output

    6
    3

    题意是给出一个数,求每一位的和,如24,就是2+4=6。如果得到的数还是大于等于10的数,就对这个数继续求每一位的和,直到变成个位数。如39>12->3。

    不能更标准的递归了。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    using namespace std;
    
    string out;
    
    void recursion(string test)
    {
    	if(test.length()==1)
    	{
    		out=test;
    		return;
    	}
    	int i,result=0;
    	for(i=0;i<test.length();i++)
    	{
    		result += test[i]-'0';
    	}
    	int temp;
    	string test2;
    	while(result!=0)
    	{
    		temp=result%10;
    		test2 += temp+'0';
    		result /=10;
    	}
    	recursion(test2);
    }
    
    int main()
    {	
    	string test;
    	
    	while(cin>>test)
    	{
    		if(test=="0")
    			break;
    		recursion(test);
    		cout<<out<<endl;
    	}
    	return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    Sass
    将100以内同时能被3和5整除的数输出
    Html小插件
    微信小程序一些demo链接地址
    .net MVC4一个登陆界面加验证
    Zeu.js
    Google 开发的、最好用、功能最强大的网页测速与网站性能分析工具
    .net基本面试题
    C#简单的九九乘法表
    请编程实现一个冒泡排序算法
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785802.html
Copyright © 2020-2023  润新知