• POJ 1466:Girls and Boys 二分图的最大点独立集


    Girls and Boys
    Time Limit: 5000MS   Memory Limit: 10000K
    Total Submissions: 11097   Accepted: 4960

    Description

    In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

    Input

    The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description: 

    the number of students 
    the description of each student, in the following format 
    student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ... 
    or 
    student_identifier:(0) 

    The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

    Output

    For each given data set, the program should write to standard output a line containing the result.

    Sample Input

    7
    0: (3) 4 5 6
    1: (2) 4 6
    2: (0)
    3: (0)
    4: (2) 0 1
    5: (1) 0
    6: (2) 0 1
    3
    0: (2) 1 2
    1: (1) 0
    2: (1) 0

    Sample Output

    5
    2

    有一堆男生和女生,有的男生对女生喜欢,对应的女生也喜欢相应的男生。现在要找到一个集合,里面的人互相都没有感觉,问这个集合中的最大人数。

    误打误撞了最大独立集,这道题的二分图的最大独立集=所有节点的数量-最大匹配数量/2。上面的这个也是有要求的,就是喜欢的女生恰好也喜欢你,每两个点上都有两条边,每一次都重复算了一次。要是不是这样,每次喜欢的人的关系不确定喜不喜欢你,我觉得解起来还会麻烦一些。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    int grid[805][805];
    int link[805];
    int visit[805];
    int n,k,V1,V2;
    int result;
    
    bool dfs(int x)
    {
    	int i;
    	for(i=0;i<V2;i++)
    	{
    		if(grid[x][i]==1&&visit[i]==0)
    		{
    			visit[i]=1;
    			if(link[i]==-1||dfs(link[i]))
    			{
    				link[i]=x;
    				return true;
    			}
    		}
    	}
    	return false;
    }
    
    void Magyarors()
    {
    	int i;
    	
    	result=0;
    	memset(link,-1,sizeof(link));//!!这里不能是0
    
    	for(i=0;i<V1;i++)
    	{
    		memset(visit,0,sizeof(visit));
    		if(dfs(i))
    			result++;
    	}
    	cout<<n-result/2<<endl;
    }
    
    int main()
    {
    	int i,j,temp1,temp2,temp3;
    	while(scanf("%d",&n)!=EOF)
    	{
    		memset(grid,0,sizeof(grid));
    		V1=V2=n;
    		for(i=0;i<n;i++)
    		{
    			scanf("%d: (%d)",&temp1,&temp2);
    			for(j=1;j<=temp2;j++)
    			{
    				scanf("%d",&temp3);
    				grid[temp1][temp3]=1;
    			}
    		}
    		Magyarors();
    	}
    	return 0;
    }
    



    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    1scala基础
    3scala高级
    03spark kafka
    01spark基础
    04spark streaming
    2scala集合
    02spark sql
    学习java程序设计环境的心得
    第五章继承
    第二周学习Java心得
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785771.html
Copyright © 2020-2023  润新知