• A1011. World Cup Betting (20)


    With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

    Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

    For example, 3 games' odds are given as the following:

     W    T    L
    1.1  2.5  1.7
    1.2  3.0  1.6
    4.1  1.2  1.1
    

    To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

    Input

    Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

    Output

    For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

    Sample Input

    1.1 2.5 1.7
    1.2 3.0 1.6
    4.1 1.2 1.1
    

    Sample Output

    T T W 37.98
    // hahaha.cpp : 定义控制台应用程序的入口点。
    //
    
    #include <stdafx.h>
    #include <stdio.h>
    #include <iostream>
    #include <vector>
    #include <map>
    #include <string>
    #include <cstdio>
    #include <set>
    #include <algorithm>
    #include <string.h>
    #include <string.h>
    using namespace std;
    
    typedef long long LL;
    
    char s[3]={'W','T','L'};
    
    int main()
    {
        double ans=1.0,tmp,a;
        int idx,num[3];
        for(int i=0;i<3;i++)
            {
            tmp=0.0;
            for(int  j=0;j<3;j++)
                {
                scanf("%lf",&a);
                if(a>tmp){
                    tmp=a;
                    idx=j;
                    }
                }
    
            ans*=tmp;
            num[i]=idx;
            }
        for(int i=0;i<3;i++)
            {
            printf("%c ",s[num[i]]);
            }
        
        printf("%.2f",(ans*0.65-1)*2);
        return 0;
    }
  • 相关阅读:
    PHP7.27: connect mysql 5.7 using new mysqli
    PHP: Browser, Operating System (OS), Device, and Language Detect
    PHP 在WIN10 下配置
    MySQL chartset
    學習Echart 2.2.7
    The open source JavaScript graphing library that powers Plotly
    D3.js 制作中国地图
    FastReport.Net
    CSS 3D transforms
    SparkCore的调优之开发调优
  • 原文地址:https://www.cnblogs.com/ligen/p/4343816.html
Copyright © 2020-2023  润新知