• POJ 1611 The Suspects(并查集)


    The Suspects

    Time Limit: 1000MS

     

    Memory Limit: 20000K

    Total Submissions: 13843

     

    Accepted: 6565

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
    Once a member in a group is a suspect, all members in the group are suspects. 
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4

    2 1 2

    5 10 13 11 12 14

    2 0 1

    2 99 2

    200 2

    1 5

    5 1 2 3 4 5

    1 0

    0 0

    Sample Output

    4

    1

    1

    Source

    Asia Kaohsiung 2003

     解题报告:这道题就是说有n个学生,编号为0 --n-1,编号为0的学生是病人,和0在一起的都是病人,看有多少人有病,就是集合的合并,最好的办法就是使用并查集;

    代码如下:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    using namespace std;
    const int N = 30010;
    int father[N],num[N];
    int n, m;
    void Makeset()//初始化
    {
    for (int i = 0; i < n; ++i)
    {
    father[i] = i;
    num[i] = 1;//集合的初始化,表明有n个集合,并且每个集合只有一个元素
    }
    }
    int Find(int i)
    {
    if (father[i] != i)
    {
    father[i] = Find(father[i]);
    }
    return father[i];//路径压缩
    }
    void Merge(int x, int y)
    {
    int i, j;
    i = Find(x);
    j = Find(y);
    if (i != j)
    {
    father[j] = i;
    num[i] += num[j];//集合的合并
    }
    }
    int main()
    {
    int i, j, x, p, q, ans;
    while (scanf("%d%d", &n, &m) != EOF)
    {
    if (n == 0 && m ==0)
    {
    break;
    }
    memset(father, 0, sizeof(father));
    memset(num, 0, sizeof(num));
    Makeset();
    for (i = 0; i < m; ++i)
    {
    scanf("%d", &x);
    scanf("%d", &p);
    for (j = 1; j < x; ++j)
    {
    scanf("%d", &q);
    Merge(p, q);//若q和p在一个集合就加进去
    }
    }
    ans = num[Find(0)];
    printf("%d\n", ans);
    }
    return 0;
    }



  • 相关阅读:
    userdefined phase 自定义uvm_phase
    从源码角度来看UVM phase
    sequence启动的三种方式
    谈一谈SystemVerilog的seed
    UVM跨domain同步
    从源码角度来看objection
    creat a uvm_sched自定义domain的run_time_phase
    Solution Set 「LOCAL」冲刺省选 Round XXVII
    Solution 「CF 1290F」Making Shapes
    Solution Set 「LOCAL」冲刺省选 Round XXII
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2400923.html
Copyright © 2020-2023  润新知