• POJ 1573 Robot Motion(简单模拟)


    Robot Motion

    Time Limit: 1000MS

     

    Memory Limit: 10000K

    Total Submissions: 7311

     

    Accepted: 3513

    Description

     


    A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

    N north (up the page) 
    S south (down the page) 
    E east (to the right on the page) 
    W west (to the left on the page) 

    For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

    Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

    You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

    Input

    There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

    Output

    For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

    Sample Input

    3 6 5

    NEESWE

    WWWESS

    SNWWWW

    4 5 1

    SESWE

    EESNW

    NWEEN

    EWSEN

    0 0 0

    Sample Output

    10 step(s) to exit

    3 step(s) before a loop of 8 step(s)

    Source

    Mid-Central USA 1999

    解题报告:这题就是简单的模拟题,在遍历的时候记录步数即可;

    代码如下:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    const int N = 1010;
    char map[N][N];
    int visit[N][N], step[N][N];//step记录步数
    int n, m, x, y, flag;
    void BFS(int k)
    {
    int i, j, p;
    i = 1;
    j = k;
    p = 1;
    flag = 0;
    while (i > 0 && j >0 && i <= n && j <= m && !visit[i][j])
    {
    visit[i][j] = 1;
    step[i][j] = p;
    p ++;
    if (map[i][j] == 'N')
    {
    i --;
    }
    else if (map[i][j] == 'S')
    {
    i ++;
    }
    else if (map[i][j] == 'E')
    {
    j ++;
    }
    else if (map[i][j] == 'W')
    {
    j --;
    }
    }
    if (visit[i][j])//形成循环的情况
    {
    flag = 1;
    x = step[i][j] - 1;
    y = p - step[i][j];
    }
    else//成功出去的情况
    {
    x = p - 1;
    }
    }
    int main()
    {
    int i, j, k;
    //freopen("1.txt","r", stdin);
    while (scanf("%d%d%d", &n, &m, &k) != EOF && n && m && k)
    {
    memset(map, 0, sizeof(map));
    memset(visit, 0, sizeof(visit));
    memset(step, 0, sizeof(step));
    getchar();//度掉回车
    for (i = 1; i <= n; ++i)
    {
    for (j = 1; j <= m; ++j)
    {
    scanf("%c", &map[i][j]);
    }
    getchar();//度掉回车
    }
    BFS(k);
    if (flag)
    {
    printf("%d step(s) before a loop of %d step(s)\n", x, y);
    }
    else
    {
    printf("%d step(s) to exit\n", x);
    }
    }
    return 0;
    }



     

  • 相关阅读:
    python中的编码与解码
    python中的迭代器
    python中高阶函数与装饰器(3)
    python中高阶函数与装饰器(2)
    python中高阶函数与装饰器
    python中几种常用的数据类型
    python 启航
    Python [习题] 字典排序
    SQL-TSQL
    SQL基础语句
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2370455.html
Copyright © 2020-2023  润新知