• POJ 2965 The Pilots Brothers' refrigerator(枚举+DFS)


    The Pilots Brothers' refrigerator
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 11462   Accepted: 4200   Special Judge

    Description

    The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

    There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

    The task is to determine the minimum number of handle switching necessary to open the refrigerator.

    Input

    The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

    Output

    The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

    Sample Input

    -+--
    ----
    ----
    -+--

    Sample Output

    6
    1 1
    1 3
    1 4
    4 1
    4 3
    4 4

    Source

    Northeastern Europe 2004, Western Subregion
    解题报告:这道题目和1753思路一样,只是要输出所执行的步骤而已,但是很变态的是在DFS函数中不能判断flag否则超时,详见代码
    代码如下:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    const int N = 10;
    struct node
    {
    int p, q;
    }a[18];
    int map[N][N], ans, flag;
    void Change(int x, int y) //翻转函数
    {
    int i;
    map[x][y] = !map[x][y];
    for (i = 1; i <= 4; ++i)
    {
    map[x][i] = !map[x][i];
    map[i][y] = !map[i][y];
    }
    }
    int Judge() //判断函数
    {
    int i, j;
    for (i = 1; i <= 4; ++i)
    {
    for (j = 1; j <= 4; ++j)
    {
    if (map[i][j] == 0)
    {
    return 0;
    }
    }
    }
    return 1;
    }
    void DFS(int x, int y, int step)
    {
    if (step == ans)
    {
    flag = Judge();//不能加if(flag),否则超时
    return ;
    }
    if (flag || x >= 5)
    {
    return ;
    }
    Change(x, y);
    if (y < 4)
    {
    DFS(x, y + 1, step + 1);
    a[step].p = x;
    a[step].q = y;
    }
    else
    {
    DFS(x + 1, 1, step + 1);
    a[step].p = x;
    a[step].q = y;
    }
    Change(x, y);
    if (y < 4)
    {
    DFS(x, y + 1, step);
    }
    else
    {
    DFS(x + 1, 1, step);
    }
    }
    int main()
    {
    int i, j;
    char str;
    for (i = 1; i <= 4; ++i)
    {
    for (j = 1; j <= 4; ++j)
    {
    scanf("%c", &str);
    if (str == '-')
    {
    map[i][j] = 1;
    }
    else
    {
    map[i][j] = 0;
    }
    }
    getchar();//度掉回车
    }
    flag = 0;
    for (i = 0; i <= 16; ++i)
    {
    ans = i;
    DFS(1, 1, 0);
    if (flag)
    {
    break;
    }
    }
    if (flag)
    {
    printf("%d\n", ans);
    for (i = 0; i < ans; ++i)
    {
    printf("%d %d\n", a[i].p, a[i].q);
    }
    }
    return 0;
    }
  • 相关阅读:
    sqlserver2000及以上版本导出数据到mysql里的详细图解
    JDBC和ODBC的区别何在?什么是ODBC?
    mysql ODBC 在64位下提示找不到odbc驱动问题
    Microsoft sqlserver2000如何导入.mdf格式的数据库文件
    使用navicat 链接sql server 出现08001错误
    sql语句如何转成hql语句?
    显示所有SAP图标的ABAP代码
    SMW0上传EXCEL模板时报错无分配给对象***的MIME类型
    显示小闹钟的函数
    便携计算器
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2363917.html
Copyright © 2020-2023  润新知