• HDU 1062 Text Reverse(简单模拟)


    Text Reverse

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 7548    Accepted Submission(s): 2869

    Problem Description

    Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them. 

    Input

    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single line with several words. There will be at most 1000 characters in a line.

    Output

    For each test case, you should output the text which is processed.

    Sample Input

    3

    olleh !dlrow

    m'I morf .udh

    I ekil .mca 

    Sample Output

    hello world!

    I'm from hdu.

    I like acm.

    Hint

    Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

    Author

    Ignatius.L

    解题报告:

    简单的处理字符串问题,如果遇见字符串问题要合理利用getchar(),在注意处理边界问题

    代码如下:
    #include <iostream>
    #include <cstring>
    using namespace std;
    char str[1001];
    int main()
    {
    int i, len, n, j;
    scanf("%d", &n);
    getchar();//度掉回车
    while (n --)
    {
    gets(str);//gets()函数是以回车作为结束标志
    len = strlen(str);
    for (i = 0; i < len; ++i)
    {
    if (str[i]== ' ')
    {
    j = i - 1;
    while (str[j] != ' '&&j >=0)
    {
    printf("%c", str[j]);
    j --;
    }
    printf(" ");
    }
    else if (i == len - 1)//对最后一个单词的处理
    {
    j = i;
    while (str[j] != ' '&&j >=0)
    {
    printf("%c", str[j]);
    j --;
    }
    }
    }
    printf("\n");
    }
    return 0;
    }

     

  • 相关阅读:
    闭包总结
    执行上下文总结
    下拉列表
    练习 九九乘法表
    JavaScript中break和continue的区别
    JaveScript遍历数组的方法
    将一个块级元素水平和垂直居中的方法
    ECMAScript 中最常见的一个问题是字符串连接的性能
    JS 一些题目 难点
    JS闭包
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2345511.html
Copyright © 2020-2023  润新知