• HDU 1081 To The Max(最大连续子序列和(二维))


    To The Max

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3805    Accepted Submission(s): 1816

    Problem Description

    Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
    As an example, the maximal sub-rectangle of the array:

    0 -2 -7 0
    9 2 -6 2
    -4 1 -4 1
    -1 8 0 -2

    is in the lower left corner:

    9 2
    -4 1
    -1 8

    and has a sum of 15.

    Input

    The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

    Output

    Output the sum of the maximal sub-rectangle.

    Sample Input

    4

    0 -2 -7 0 9 2 -6 2

    -4 1 -4 1 -1

    8 0 -2

    Sample Output

    15

    Source

    Greater New York 2001

    解题报告:题意:求一个二维矩阵的最大子矩阵的和(最大子段和的推广),方法就是把二维的转化为一维的,

    代码如下:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    using namespace std;
    const int N= 110;
    int a[N][N],sum[N];
    int main()
    {
    //freopen("1002.txt","r",stdin);
    int n,i,j,k,sum1,max,ans;
    while(scanf("%d",&n)!=EOF)
    {
    memset(a,0,sizeof(a));
    for(i=1;i<=n;i++)
    {
    for(j=1;j<=n;j++)
    {
    scanf("%d",&a[i][j]);
    }
    }
    ans=-99999;
    for(i=1;i<=n;i++)
    {
    memset(sum,0,sizeof(sum));
    for(j=i;j<=n;j++)//将二维压缩成一维的
    {
    for(k=1;k<=n;k++)
    {
    sum[k]+=a[j][k];
    }
    max=-99999;
    sum1=0;
    for(k=1;k<=n;k++)//求最大值
    {
    if(sum1>0)
    {
    sum1+=sum[k];
    }
    else
    {
    sum1=sum[k];
    }
    if(max<sum1)
    {
    max=sum1;
    }
    }
    if(ans<max)
    {
    ans=max;
    }
    }
    }
    printf("%d\n",ans);
    }
    }



  • 相关阅读:
    CPDA之时间序列
    CSS clear
    27 款经典的CSS 框架
    IT人必读:请不要做浮躁的IT人
    23个Javascript弹出窗口特效
    三种东西永远不要放到数据库里
    jquery 插件 thickbox窗口 第一个控件获得焦点(解决第二次弹出窗口,文本不能输入数据)
    enum总结
    vs版本的选择
    iPhone iPad 各种控件默认高度
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2270848.html
Copyright © 2020-2023  润新知