Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5568 Accepted Submission(s): 3925
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
Author
Ignatius.L
解题报告:做这个题的时候以为是找规律的题呢!找了半个多小时的规律也没有找出!哎最后问了队友才知道这题得利用母函数的知识解决,于是在网上找了关于母函数的模板!
将整数拆分问题转化为求多项式相乘后的系数!
代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N=10010;
//c1数组保存各项组合的数目c2数组是中间变量保存每一次的情况
int c1[N],c2[N];
int main()
{
int n,i,j,k;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<=n;i++)//因为是第一个表达式(1+x+x2+..xn)所以c1数组初始化为1,
{
c1[i]=1;
c2[i]=0;
}
for(i=2;i<=n;i++)//从2遍历,求每一个表达式
{
//j 从0到n遍历,这里j就是(前面i个表达式累乘的表达式)里第j个变量
for(j=0;j<=n;j++)
{
for(k=0;k+j<=n;k=k+i)//k表示的是第j个指数,因为第i个表达式的增量是i,所以k每次增i
{
c2[k+j]=c2[k+j]+c1[j];
}
}
for(j=0;j<=n;j++)
{
c1[j]=c2[j];//因为c2每次是从一个表达式中开始的,把c2的值赋给c1,而把c2初始化为0.
c2[j]=0;
}
}
printf("%d\n",c1[n]);//X的n次方的系数即为所求
}
return 0;
}