• Uva 712 STrees


      S-Trees 

    A Strange Tree (S-tree) over the variable set $X_n = \{x_1, x_2, \dots, x_n\}$ is a binary tree representing a Boolean function $f: \{0, 1\}^n \rightarrow \{ 0, 1\}$. Each path of the S-tree begins at the root node and consists of n+1 nodes. Each of the S-tree's nodes has a depth, which is the amount of nodes between itself and the root (so the root has depth 0). The nodes with depth less than n are called non-terminal nodes. All non-terminal nodes have two children: the right child and the left child. Each non-terminal node is marked with some variablexi from the variable set Xn. All non-terminal nodes with the same depth are marked with the same variable, and non-terminal nodes with different depth are marked with different variables. So, there is a unique variable xi1 corresponding to the root, a unique variable xi2 corresponding to the nodes with depth 1, and so on. The sequence of the variables $x_{i_1}, x_{i_2}, \dots, x_{i_n}$ is called the variable ordering. The nodes having depth nare called terminal nodes. They have no children and are marked with either 0 or 1. Note that the variable ordering and the distribution of 0's and 1's on terminal nodes are sufficient to completely describe an S-tree.

    As stated earlier, each S-tree represents a Boolean function f. If you have an S-tree and values for the variables $x_1, x_2, \dots, x_n$, then it is quite simple to find out what $f(x_1, x_2, \dots, x_n)$ is: start with the root. Now repeat the following: if the node you are at is labelled with a variable xi, then depending on whether the value of the variable is 1 or 0, you go its right or left child, respectively. Once you reach a terminal node, its label gives the value of the function.

    Figure 1: S-trees for the function $x_1 \wedge (x_2 \vee x_3)$

    On the picture, two S-trees representing the same Boolean function, $f(x_1, x_2, x_3) = x_1 \wedge (x_2 \vee x_3)$, are shown. For the left tree, the variable ordering is x1x2x3, and for the right tree it is x3x1x2.

    The values of the variables $x_1, x_2, \dots, x_n$, are given as a Variable Values Assignment (VVA) 

    \begin{displaymath}(x_1 = b_1, x_2 = b_2, \dots, x_n = b_n)
\end{displaymath}

    with $b_1, b_2, \dots, b_n \in \{0,1\}$. For instance, ( x1 = 1, x2 = 1 x3 = 0) would be a valid VVA for n = 3, resulting for the sample function above in the value $f(1, 1, 0) = 1 \wedge (1 \vee 0) = 1$. The corresponding paths are shown bold in the picture.

    Your task is to write a program which takes an S-tree and some VVAs and computes $f(x_1, x_2, \dots, x_n)$ as described above.

    Input 

    The input file contains the description of several S-trees with associated VVAs which you have to process. Each description begins with a line containing a single integer n$1 \le n \le 7$, the depth of the S-tree. This is followed by a line describing the variable ordering of the S-tree. The format of that line is xi1 xi2...xin. (There will be exactly n different space-separated strings). So, for n = 3 and the variable orderingx3x1x2, this line would look as follows:

    x3 x1 x2

    In the next line the distribution of 0's and 1's over the terminal nodes is given. There will be exactly 2ncharacters (each of which can be 0 or 1), followed by the new-line character. The characters are given in the order in which they appear in the S-tree, the first character corresponds to the leftmost terminal node of the S-tree, the last one to its rightmost terminal node.

    The next line contains a single integer m, the number of VVAs, followed by m lines describing them. Each of the m lines contains exactly n characters (each of which can be 0 or 1), followed by a new-line character. Regardless of the variable ordering of the S-tree, the first character always describes the value of x1, the second character describes the value of x2, and so on. So, the line

    110

    corresponds to the VVA ( x1 = 1, x2 = 1, x3 = 0).

    The input is terminated by a test case starting with n = 0. This test case should not be processed.

    Output 

    For each S-tree, output the line ``S-Tree #j:", where j is the number of the S-tree. Then print a line that contains the value of $f(x_1, x_2, \dots, x_n)$ for each of the given m VVAs, where f is the function defined by the S-tree.

    Output a blank line after each test case.

    Sample Input 

    3
    x1 x2 x3
    00000111
    4
    000
    010
    111
    110
    3
    x3 x1 x2
    00010011
    4
    000
    010
    111
    110
    0
    

    Sample Output 

    S-Tree #1:
    0011
    
    S-Tree #2:
    0011
    

    Miguel A. Revilla 
    2000-02-09
     
    #include<stdio.h>
    #include<string.h>
    #include<math.h>
    #include<ctype.h>
    #define MAXN 300
    
    int operation(int i, int *tree, int len)
    {//找到叶子节点的值并返回 
        if(2*i+2 >= len) return tree[i];
        else
        {
            if(tree[i] == 0) return operation(2*i+1, tree, len);
            else return operation(2*i+2, tree, len);
        }
    }
    
    int main()
    {
    
        int n, i, j, m, sum, temp, flag, t, times, k, cnt = 0;
        int s_Tree[MAXN], order[10], read[10];
        char ch;
        while(scanf("%d", &n) != EOF && n)
        {
            getchar();
            i = flag = 0;
            memset(order, 0, sizeof(order));
            while((ch = getchar()) != '\n')
            {//处理输入,将xn中的数放到数组order中 
                if(isdigit(ch))
                {
                    order[i] = order[i]*10 + (ch - '0');
                    flag = 1;
                }
                else if(flag == 1)
                {
                    i++;
                    flag = 0;
                }
            }
            memset(s_Tree, 0, sizeof(s_Tree));
            sum = (int)pow(2.0, (double)n) - 1; //找到叶子节点的存储位置先 
            m = (int)pow(2.0, (double)n);//叶子节点的数量 
            for(i=0; i<m; ++i, ++sum)
            {//存放叶子节点的值 
                ch = getchar();
                s_Tree[sum] = ch - '0';
            }
            scanf("%d", &m);
            getchar();
            for(i=0; i<m; ++i)
            {//存放xn的0/1值到数组read中 
                for(j=1; j<=n; ++j)
                {
                    ch = getchar();
                    read[j] = ch - '0';
                }
                getchar();
                for(k=t=0; t<n; ++t)
                {//设定各非叶子节点的值即0或者1 
                    times = (int)pow(2.0, (double)t);
                    while(times--) s_Tree[k++] = read[order[t]];
                }
                if(i == 0) printf("S-Tree #%d:\n", ++cnt);
                printf("%d", operation(0, s_Tree, sum));
            }
            printf("\n\n");
        }
        return 0;
    }

    解题思路:

    简单题,所以还是跟以前一样,建树,不过因为这次是层次遍历的模式,所以用数组存储各节点的值,最后根据父和子节点的关系找到最终的值

  • 相关阅读:
    iOS开发UI篇—简单介绍静态单元格的使用
    iOS开发UI篇—UITableview控件使用小结
    iOS开发UI篇—使用纯代码自定义UItableviewcell实现一个简单的微博界面布局
    iOS开发UI篇—使用xib自定义UItableviewcell实现一个简单的团购应用界面布局
    iOS开发UI篇—实现UItableview控件数据刷新
    iOS开发UI篇—使用嵌套模型完成的一个简单汽车图标展示程序
    iOS开发UI篇—UITableviewcell的性能问题
    iOS开发UI篇—UITableview控件基本使用
    iOS开发UI篇—UITableview控件简单介绍
    A1055. The World's Richest
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2981273.html
Copyright © 2020-2023  润新知