• HDU ACM 1232 畅通工程


    畅通工程

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 18861    Accepted Submission(s): 9705


    Problem Description
    某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 
     
    Input
    测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
    注意:两个城市之间可以有多条道路相通,也就是说
    3 3
    1 2
    1 2
    2 1
    这种输入也是合法的
    当N为0时,输入结束,该用例不被处理。 
     
    Output
    对每个测试用例,在1行里输出最少还需要建设的道路数目。 
     
    Sample Input
    4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
     
    Sample Output
    1 0 2 998
    Hint
    Hint
    Huge input, scanf is recommended.
     
    Source
     
    Recommend
    JGShining
     
    #include<stdio.h>
    #include<string.h>
    int father[1002];
    
    int find(int n)
    {
        if(father[n] == n) return n;
        else return father[n] = find(father[n]);
    }
    
    int main()
    {
        int n, m, T, x, y, cnt, i, j;
        while(scanf("%d", &n) != EOF && n != 0)
        {
            scanf("%d", &m);
            cnt = 0;
            for(i=0; i<n; ++i) father[i] = i;
            for(i=0; i<m; ++i) 
            {
                scanf("%d%d", &x, &y);
                x = find(x-1), y = find(y-1);
                if(x != y) father[x] = y;
            }
            for(i=0; i<n; ++i) if(father[i] == i) cnt++;
            printf("%d\n", cnt-1);  //最后输出的是路径,所以要-1 
        }
        return 0;
    }
  • 相关阅读:
    hbase过滤器(1)
    公司jar包提交到集群的方法
    hbase Hfile处理原因
    oracle pl/sql远程连接过程
    mapreduce join操作
    HTML不熟悉方法总结
    Ajax详解
    getElementById和querySelector区别
    Session
    ES6模块化
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2821719.html
Copyright © 2020-2023  润新知