• HDU ACM 1048 The Hardest Problem Ever (水题)


    The Hardest Problem Ever

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 11145    Accepted Submission(s): 4997


    Problem Description
    Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked. 
    You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite: 

    Cipher text
    A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

    Plain text
    V W X Y Z A B C D E F G H I J K L M N O P Q R S T U 

    Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.
     
    Input
    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase. 

    A single data set has 3 components: 

    Start line - A single line, "START" 

    Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar 

    End line - A single line, "END" 

    Following the final data set will be a single line, "ENDOFINPUT".
     
    Output
    For each data set, there will be exactly one line of output. This is the original message by Caesar.
     
    Sample Input
    START NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX END START N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ END START IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ END ENDOFINPUT
    Sample Output
    IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE
     
    Source
     
    #include<stdio.h>
    #include<string.h>
    #include<ctype.h>
    int main()
    {
        char mes[220], Cipher[]="ABCDEFGHIJKLMNOPQRSTUVWXYZ";
        char ope[15];
        int i, len, loc;
        memset(ope, '\0', sizeof(ope));
        while(scanf("%s", ope) != EOF && !strcmp(ope, "START"))
        {
            getchar();
            memset(mes, '\0', sizeof(mes));
            fgets(mes, 220, stdin);
            len = strlen(mes) - 1;
            for(i=0; i<len; ++i)
            {
                if(isalpha(mes[i])) 
                {
                    loc = strchr(Cipher, mes[i]) - Cipher;
                    putchar(Cipher[(26 + loc - 5)%26]); 
                }
                else putchar(mes[i]);
            }
            printf("\n");
            scanf("%s", ope);
            memset(ope, '\0', sizeof(ope));
        }
    } 
  • 相关阅读:
    java基础知识回顾之final
    基础知识《十四》Java异常的栈轨迹fillInStackTrace和printStackTrace的用法
    基础知识《六》---Java集合类: Set、List、Map、Queue使用场景梳理
    基础知识《五》---Java多线程的常见陷阱
    基础知识《四》---Java多线程学习总结
    《转》如何选择合适的服务器托管商
    基础知识《三》java修饰符
    基础知识《零》---Java程序运行机制及运行过程
    应用 JD-Eclipse 插件实现 RFT 中 .class 文件的反向编译
    DOS命令符基本操作
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2783748.html
Copyright © 2020-2023  润新知