• hdoj_1160FatMouse's Speed


    FatMouse's Speed

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5806    Accepted Submission(s): 2504
    Special Judge


    Problem Description
    FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
     

    Input
    Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

    The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

    Two mice may have the same weight, the same speed, or even the same weight and speed. 
     

    Output
    Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

    W[m[1]] < W[m[2]] < ... < W[m[n]]

    and 

    S[m[1]] > S[m[2]] > ... > S[m[n]]

    In order for the answer to be correct, n should be as large as possible.
    All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
     

    Sample Input
    6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
     
    Sample Output
    4 4 5 9
    7 //=.=
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <algorithm>
    using namespace std;
    
    struct Point{
    	int weight;
    	int speed;
    	int num;
    	int pre;
    }mice[1005];
    
    bool cmp(Point a, Point b)
    {
    	if(a.weight == b.weight) return a.speed > b.speed;
    	else return a.weight < b.weight;
    }
    
    //void output(int k)
    //{
    //	if(k<=0) return;
    //	output(mice[k].pre);
    //	cout<<mice[k].num<<endl;
    //}
    
    int main()
    {
    	freopen("E:\\ACM\\HDOJ\\hdoj_1160\\in.txt","r",stdin);
    	int i, j, v = 1, flag, max;
    	int dp[1005] = {0};
    	while(scanf("%d %d", &mice[v].weight, &mice[v].speed)!=EOF)
    	{
    		mice[v].num = v++;
    	}
    	v--;
    	sort(mice+1, mice+v+1, cmp);
    
    	max = 0;
    	for(i = 1; i <= v;  i++)
    	{
    		dp[i] = 1;
    		for(j = 1; j < i; j++)
    		{
    			if(mice[i].weight > mice[j].weight && mice[i].speed < mice[j].speed && dp[j] +1 > dp[i] )
    			{
    				dp[i] = dp[j] + 1;
    				mice[i].pre = j;
    				if(dp[i] > max)
    				{
    					max = dp[i];
    					flag = i;
    				}
    			}
    		}
    	}
    
    	cout << max << endl;
    	int ans[1005];
    	j = 1;
    	for( i = 1; i <= max; i++)
    	{
    		ans[j++] = mice[flag].num;
    		flag = mice[flag].pre;
    	}
    	for( i = max; i >= 1; i--)
    	{
    		cout<<ans[i]<<endl;
    	}
    	return 0;
    }


    
    
  • 相关阅读:
    vscode中golang插件配置
    好用的go开源模块汇总
    常用linux指令
    读大嘴生平咨询---->关于商业模式的思考
    photoprism 源码阅读
    C语言的算法
    C语言输出函数和输入函数
    C语言基本概念
    servlet(3)
    servlet(2)
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835288.html
Copyright © 2020-2023  润新知