• poj_2262Goldbach's Conjecture


    Goldbach's Conjecture
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 32564   Accepted: 12542

    Description

    In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
    Every even number greater than 4 can be 
    written as the sum of two odd prime numbers.

    For example: 
    8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
    20 = 3 + 17 = 7 + 13. 
    42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

    Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
    Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

    Input

    The input will contain one or more test cases. 
    Each test case consists of one even integer n with 6 <= n < 1000000. 
    Input will be terminated by a value of 0 for n.

    Output

    For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

    Sample Input

    8
    20
    42
    0
    

    Sample Output

    8 = 3 + 5
    20 = 3 + 17
    42 = 5 + 37
    
    
    筛法求素数
    
    
    #include <iostream>
    #include <cmath>
    #include <vector>
    #include <cstring>
    using namespace std;
    #define MAX 1000001
    vector<int>primer(MAX);
    
    void pri()
    {
    	for(int i = 1; i < MAX; i++)
    	{
    		primer[i] = 1;
    	}
    	primer[0] = 0;
    	primer[1] = 0;
    	for(int i = 2; i < MAX / 2; i++)
    	{
    		for(int j = 2; i * j < MAX; j++)
    		{
    			primer[i*j] = 0;
    		}
    	}
    }
    
    int main()
    {
    	int n;
    	bool flag;
    	pri();
    	while(cin >> n)
    	{
    		flag = false;
    		if(n == 0) break;
    		for(int i = 2; i <= n; i++)
    		{
    			if(primer[i] && primer[n-i])
    			{
    				cout << n << " = " << i << " + " << n-i << endl;
    				flag = true;
    				break;
    			}
    		}
    		if(!flag) cout << "Goldbach's conjecture is wrong." << endl;
    	}
    }


  • 相关阅读:
    史上最简单易懂的Android Pad手机屏幕适配方案
    Android平板开发
    Android TV 开发 (1)
    三大开源java区块链库
    将博客园数据导出到wordpress
    MQTT结构分析
    netty+mqtt
    安卓原生 VideoView实现rtsp流媒体的播放
    【矩阵专题】——矩阵加速
    征战蓝桥 —— 2016年第七届 —— C/C++A组第4题——快速排序
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835132.html
Copyright © 2020-2023  润新知