• Digital Roots


    Problem Description

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

    Input

    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

    Output

    For each integer in the input, output its digital root on a separate line of the output.

    Sample Input

    24
    39
    0
    

    Sample Output

    6
    3
    

    Source

    Greater New York 2000




    #include <iostream>
    #include<string>
    using namespace std;


    string a;
    int main()
    {


        while(cin>>a&&a!="0")
        {int n=0;
    for(int a_index = 0; a_index < a.length(); a_index++)
        {
        n= (a[a_index] - '0')+n;
        if(n>9)
            n=n%10+n/10;}
        cout<<n<<endl;}


        return 0;
        }


  • 相关阅读:
    sql 相关子查询
    sql 执行计划
    SQL表连接查询(inner join、full join、left join、right join)
    sql执行顺序
    sql 语句 嵌套子查询 执行顺序分析
    只有程序员才看得懂的情书
    Give Me an E
    hdu 1114 (背包变形)
    模版 并查集
    背包 讲解
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387875.html
Copyright © 2020-2023  润新知