• Fence Repair(优先队列容器的应用)


    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks 
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    #include <iostream>
    #include <queue>
    using namespace std;
    int main()
    {
     
     int n;
     while(cin>>n)
     {priority_queue<int ,vector<int>,greater<int> >q;
     int i,x,y;
     for(i=0;i<n;i++){
      cin>>x;q.push(x);
     }
     
     long long  count=0 ;
     while(q.size()>1)
     {x=q.top();
     q.pop();
     y=q.top();
     q.pop();
     count+=(x+y);
     q.push(x+y);
     
     
     }printf("%lld ",count);
     
     }
     return 0;
     
    }

  • 相关阅读:
    hive 求多列中的最大值、最小值
    HIVE UDAF 编写
    JAVA实现接口
    hivegrouping sets用法及grouping_id计算方法
    好用的开源项目
    Vue2切换生产环境、测试环境和开发环境
    hping3工具使用介绍
    Slowhttptest工具介绍
    输出字符菱形
    windows平台下sublime配置python开发环境
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387807.html
Copyright © 2020-2023  润新知