• stars


    B - Stars
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

    Description

    Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



    For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

    You are to write a program that will count the amounts of the stars of each level on a given map.
     

    Input

    The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
     

    Output

    The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
     

    Sample Input

    5 1 1 5 1 7 1 3 3 5 5
     

    Sample Output

    1 2 1 1 0
     


    #include <iostream>
    #include <string.h>
    #include <stdio.h>
    using namespace std;
    const int maxn = 32005;
    int c[maxn];
    int ans[maxn];
    int lowbit(int x)  {
        return x&(-x);
    }
    void add(int x){
        while(x<=maxn){
            c[x]+=1;   x+=lowbit(x);
        }
    }
    int sum(int x){
        int ret=0;
        while(x>0){
           ret+=c[x];  x-=lowbit(x);
        }
        return ret;
    }
    int main(){
        int n,x,y,i;
        while(scanf("%d",&n)!=EOF){
            memset(ans,0,sizeof(ans));
            memset(c,0,sizeof(c));
            for(i=0;i<n;i++){
                 scanf("%d %d",&x,&y);

                 ans[ sum(++x)]++;

                 add(x);
            }
            for(i=0;i<n;i++)
            printf("%d ",ans[i]);

        }

       return 0;
    }

  • 相关阅读:
    Spring Boot整合JPA
    Emmet Cheat Sheet All In One
    CCTV《航拍中国》系列视频 All In One
    上海市税务局服务 All In One
    CCTV 天气预报 All In One
    Next.js Tutorials All In One
    如何使用 GitHub Actions 发布 Gatsby 静态网站 All In One
    GitHub Code Security & Code Scanning All In One
    数字滚动显示组件 All In One
    Gatsby plugins All In One
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387803.html
Copyright © 2020-2023  润新知