• Agri-Net(最小生成树)


    Agri-Net
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 39960   Accepted: 16256

    Description

    Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
    Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
    Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
    The distance between any two farms will not exceed 100,000. 

    Input

    The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

    Output

    For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

    Sample Input

    4
    0 4 9 21
    4 0 8 17
    9 8 0 16
    21 17 16 0
    

    Sample Output

    28

    Source

    #include<iostream>
    using namespace std;
    int p[105][105],x,y,vis[105],i,j;
    int main()




    { int n;
    while (scanf("%d", &n) != EOF)
    {
    memset(p,0,sizeof(p));

    for(i=1;i<=n;i++)
    for(j=1;j<=n;j++)
    cin>>p[i][j];
    memset(vis,0,sizeof(vis));
    vis[1]=1;
    int sum=0;
    for(i=0;i<n-1;i++)
    {int  max=1000000;
    for(j=1;j<=n;j++)
    {if(!vis[j]&&p[1][j]<max)
    {max=p[1][j];
    x=j;}
    }
    vis[x]=1;
    sum+=max;
    for(j=1;j<=n;j++)
    {if(!vis[j]&&p[1][j]>p[x][j])
    p[1][j]=p[x][j];


    }
    }


    cout<<sum<<endl;


    }
    return 0;}









     

  • 相关阅读:
    [转]JavaScript和html5 canvas生成圆形印章
    [转]微信小程序开发:http请求
    [转]Clean up after Visual Studio
    [转]How to Clean the Global Assembly Cache
    [转].NET Core dotnet 命令大全
    [转].NET 4.5+项目迁移.NET Core的问题记录 HTTP Error 502.5
    [转]How do I run msbuild from the command line using Windows SDK 7.1?
    [转]glyphicons-halflings-regular字体 图标
    [转]程序集之GAC---Global Assembly Cache
    [转]How can I install the VS2017 version of msbuild on a build server without installing the IDE?
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387800.html
Copyright © 2020-2023  润新知