• poj 1028 Web Navigation


    Description

    Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.
    The following commands need to be supported:
    BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.
    FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.
    VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.
    QUIT: Quit the browser.
    Assume that the browser initially loads the web page at the URL http://www.acm.org/

    Input

    Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

    Output

    For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

    Sample Input

    VISIT http://acm.ashland.edu/
    VISIT http://acm.baylor.edu/acmicpc/
    BACK
    BACK
    BACK
    FORWARD
    VISIT http://www.ibm.com/
    BACK
    BACK
    FORWARD
    FORWARD
    FORWARD
    QUIT

    Sample Output

    http://acm.ashland.edu/
    http://acm.baylor.edu/acmicpc/
    http://acm.ashland.edu/
    http://www.acm.org/
    Ignored
    http://acm.ashland.edu/
    http://www.ibm.com/
    http://acm.ashland.edu/
    http://www.acm.org/
    http://acm.ashland.edu/
    http://www.ibm.com/
    Ignored
    
    
    
    
    
    
    简单数组运用
    、
    
    
    
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <string>
    using namespace std;
    int main()
    {int t=0,c[10000];
      memset(c,0,sizeof(c));
     string a[10000];
      a[0]="http://www.acm.org/";
    c[0]=1;
    string b;
    while(cin>>b&&b[0]!='Q')
    {
    
    
    
    if(b[0]=='V')
    {t++;
        cin>>a[t];
    cout<<a[t]<<endl;
    c[t]=1;
    int j=t+1;
    while(c[j]!=0)
    {c[j]=0;
    }
    }
    
    if(b[0]=='B')
    {if(t==0)cout<<"Ignored"<<endl;
    else{ t--;cout<<a[t]<<endl;
    }
    }
    if(b[0]=='F')
    {if(c[t+1]==0)
    cout<<"Ignored"<<endl;
    else{t++; cout<<a[t]<<endl;
    }
    
    }
    
    
    
    
    
    }
    return 0;
    }



  • 相关阅读:
    数据库建表的时候报 “1215 Cannot add foreign key constraint”
    Maven项目中提示:Eclipse “cannot be resolved to a type” error
    数据表设计的几个简单原则
    使用brew安装软件
    linux如何设置用户权限
    前端页面——Cookie与Session有什么区别
    Git Push 避免用户名和密码方法
    $GLOBALS['HTTP_RAW_POST_DATA'] 和$_POST的区别
    PHP获取POST的原始数据的方法
    PHP底层的运行机制与原理
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387795.html
Copyright © 2020-2023  润新知