• K


    Description

    When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN. 

    There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS. 

    To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds. 

    Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
     

    Input

    The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
     

    Output

    Output one line for each test, indicates the minimum HP loss.
     

    Sample Input

    1
    102
    2
    100 1
    1 100
     

    Sample Output

    20
    201
     
    AC代码:
    #include <iostream>
    #include<cstdio>
    #include<algorithm>//贪心法
    #include<cmath>
    #include<cstring>
    using namespace std;
    struct sa
    {
        int h,d;
        double c;
    }data[1050];
    bool cmp(sa x,sa y)
    {
    return x.c>y.c;//将最大的排在最前面
    }
    int main()
    {
        int n,k,ans,sum;
        while(~scanf("%d",&n))
        {
          sum=0;
            ans=0;
            memset(data,0,sizeof(data));//清零
            for(k=0;k<n;k++)
            {
                scanf("%d %d",&data[k].d,&data[k].h);//a[i]代表DPS,a[j]代表HP
            data[k].c=double (data[k].d)/double (data[k].h);/*求出攻击力最大HP最少的英雄*/
            sum+=data[k].d;//所有人的攻击力之和
            }
            sort(data,data+n,cmp);//将攻击力最大HP最少的英雄进行排序,由大到小
                for(int j=0;j<n;j++)
                {
                    ans+=data[j].h*sum;//当所有人都活着时
                   sum-=data[j].d;//当最强大的英雄HP用完后,他就死了,所以要减去它的攻击力
                }
                cout<<ans<<endl;
        }
        return 0;
    }//一开始漏掉了当攻击力相等,生命不同的情况
    /*思路:首先用sort函数对DPS/HPS进行排序,将最大的放在第一个;然后用一个循环算出没有人死亡时每一回合的总伤害;最后再用一个循环计算出对我的最小伤害,然后减去死亡英雄的伤害(我先杀第一个人,即攻击力最强大血量在同攻击力的人中最少的,只有当他死了总的攻击力才会改变)*/
    心得:考虑条件要完整,不能只想到一部分;然后就是这个题好有趣啊,就像自己在玩游戏一样。
     
     
     
  • 相关阅读:
    爬虫-基于scrapy-redis两种形式的分布式爬虫
    爬虫-Scrapy框架(CrawlSpider)
    爬虫-User-Agent和代理池
    爬虫-scrapy框架之递归解析和post请求
    爬虫-scrapy数据的持久化存储
    爬虫-scrapy框架简介和基础应用
    爬虫-移动端数据爬取
    爬虫-图片懒加载技术、selenium和PhantomJS
    爬虫-验证码处理
    爬虫-requests模块
  • 原文地址:https://www.cnblogs.com/lbyj/p/5682613.html
Copyright © 2020-2023  润新知