• 九度 题目1454:Piggy-Bank 完全背包


    题目1454:Piggy-Bank

    时间限制:1 秒

    内存限制:128 兆

    特殊判题:

    提交:1584

    解决:742

    题目描述:

    Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 
    But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

    输入:

    The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

    输出:

    Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

    样例输入:
    3
    10 110
    2
    1 1
    30 50
    10 110
    2
    1 1
    50 30
    1 6
    2
    10 3
    20 4
    
    样例输出:
    The minimum amount of money in the piggy-bank is 60.
    The minimum amount of money in the piggy-bank is 100.
    This is impossible.

    T代表几组数据,然后每组的第一对是E和F代表存钱罐本身的重量和加上钱以后的重量,然后是n对数据代表,可能的硬币的价值和重量
    求现在存钱罐最少可以装的钱

    #include <iostream>  
    #include <queue>  
    #include <cstdio>  
    #include <cstring>  
    #include <algorithm>  
    #include <cmath>  
    #include <cstdlib>  
    #include <string>  
    #include <map>  
    #define maxn 50010
    #define INF 0x7FFFFFFF
    using namespace std;    
    int main()  
    {  
        int T,E,F,n,dp[maxn],v[maxn],w[maxn];
        cin >> T;
        while(T--){
            cin >> E >> F >> n;
            int sum = F - E;
            for(int i=0;i<n;i++){
                cin >> v[i] >> w[i];
            }
            for(int i=1;i<=sum;i++){
                dp[i] = INF;        
            }
            dp[0] = 0;
            for(int i=0;i<n;i++){
                for(int j=w[i];j<=sum;j++){
                    if(dp[j-w[i]] != INF){
                        dp[j] = min(dp[j],dp[j-w[i]]+v[i]);
                    }
                }
            }
            if(dp[sum]!=INF){
                cout << "The minimum amount of money in the piggy-bank is " << dp[sum] << "." << endl;
            }    
            else cout << "This is impossible." << endl;    
        }
        return 0;  
    }  
    彼时当年少,莫负好时光。
  • 相关阅读:
    c#读取XML
    Javascript 自动计算生日
    Thread.currentThread()与setDaeMon(boolean c)方法
    StringBuffer类的delete()方法和deleteCharAt()方法
    getStackTrace()方法使用
    JDBC详解
    eclipse与idea路径不匹配
    Idea导入maven项目不自动识别pom.xml
    IDEA找不到或无法加载主类
    MySQL:主从复制与处从复制同步延迟
  • 原文地址:https://www.cnblogs.com/l609929321/p/7241216.html
Copyright © 2020-2023  润新知