• POJ 1979 Red and Black


    Red and Black
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 34862   Accepted: 18856

    Description

    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

    Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

    Input

    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

    '.' - a black tile 
    '#' - a red tile 
    '@' - a man on a black tile(appears exactly once in a data set) 
    The end of the input is indicated by a line consisting of two zeros. 

    Output

    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

    Sample Input

    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#.......#.
    .#########.
    ...........
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    ...@...
    ###.###
    ..#.#..
    ..#.#..
    0 0

    Sample Output

    45
    59
    6
    13
    

    Source

    #include <stdio.h>
    #include <math.h>
    #include <iostream>
    #include <string.h>
    #include <queue>
    #define maxn 105
    using namespace std;
    int n,m,num,vis[maxn][maxn];
    int dx[]={1,-1,0,0},dy[]={0,0,1,-1};
    char mapn[maxn][maxn];
    struct node
    {
        int x,y;
    };
    void bfs(int a,int b)
    {
        queue<node> q;
        node p;
        p.x = a;
        p.y = b;
        num++;
        vis[a][b] = 1;
        q.push(p);
        while(!q.empty())//加入队列的都是可以走到的点,所以只需ans++即可
        {
            node now = q.front();
            int x = now.x,y = now.y;
            q.pop();
            for(int i=0;i<4;i++)
            {
                int xx = x + dx[i];
                int yy = y + dy[i];
                if(xx<0||yy<0||xx>(n-1)||yy>(m-1)||mapn[xx][yy]=='#'||vis[xx][yy])
                     continue;
                num++;
                node tmp;
                tmp.x = xx;
                tmp.y = yy;
                q.push(tmp);
                vis[xx][yy] = 1;
            }
        }
    }
    int main()
    {
        while(cin >> m >> n)//注意这里输入的是m,n
        {
            memset(vis,0,sizeof(vis));
            num = 0;
            if(n==0||m==0)
                break;
            for(int i=0;i<n;i++)
                for(int j=0;j<m;j++)
                    cin >> mapn[i][j];
            for(int i=0;i<n;i++)
                for(int j=0;j<m;j++)
            {
                if(mapn[i][j]=='@')
                    bfs(i,j);
            }
            cout << num << endl;
        }
    }
    彼时当年少,莫负好时光。
  • 相关阅读:
    数值的扩展
    字符串的扩展
    变量的解构赋值整理
    let和const命令整理
    解析vue2.0中render:h=>h(App)的具体意思
    菜单栏的显示与隐藏
    vue的事件绑定
    CSS3实现3D地球自转行星公转
    MongoDB命令的简单操作(一)
    canvas扇形进度圈动态加载
  • 原文地址:https://www.cnblogs.com/l609929321/p/6696580.html
Copyright © 2020-2023  润新知