• Matches Game


    Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

    Input

    The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

    Output

    For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

    Sample Input

    2 45 45
    3 3 6 9
    

    Sample Output

    No
    Yes

    简单Nim游戏
    #include<iostream>
    #include<cstdio>
    using namespace std;
    
    int main()
    {
        //freopen("in.txt","r",stdin);
        int n;
        int a[21];
        while(~scanf("%d",&n))
        {
            int ans=0;
            for(int i=0;i<n;i++)
            {
                scanf("%d",&a[i]);
                ans^=a[i];
            }
            if(ans)puts("Yes");
            else puts("No");
        }
        return 0;
    }
    View Code
  • 相关阅读:
    element input number e
    地图 scatter 自定义图片
    地图某一个区域设置高亮
    echarts 获取县级json
    echarts map 阴影(重叠)
    echarts 渐变色
    echarts tooltip 超出处理
    npm 下载 zip
    axios post 下载文件
    书签 css
  • 原文地址:https://www.cnblogs.com/kuroko-ghh/p/10300334.html
Copyright © 2020-2023  润新知