• UVa 1593 Alignment of Code


    You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed at position p1 = 1; the second words on each line are printed at the minimal possible position p2, such that all first words end at or before position p2 - 2; the third words on each line are printed at the minimal possible position p3, such that all second words end at or before position p3 - 2, etc.

    For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).

    Input 

    The input file contains one or more lines of the code up to the end of file. All lines (including the last one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines in the input file.

    Output 

    Write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such that i-th word on each line starts at the same position pi.


    Note for the Sample:

    The `$ sqcup$' character in the example below denotes a space character in the actual files (ASCII code 32).

    Sample Input 

      start:  integer;    // begins here
    stop: integer; //  ends here  
     s:  string;   
    c:   char; // temp
    

    Sample Output 

    start: integer; // begins here 
    stop:  integer; // ends   here 
    s:     string;
    c:     char;    // temp
    
    
    这道题彻底的暴露了我的C++功底确实不怎么样,但也学到了不少东西。一个以vector<vector<int>>把我彻底搞晕了,用范围for和迭代器发现输出都是错的,要么每输出一个单词换行,要么之间不换行,晕了。。。最后debug发现竟然是getline直接写成了cin,导致第一遍RE。第二遍WA,是因为没有处理最后一个单词后面的空格。第三遍才AC。
    
    
    #include <bits/stdc++.h>
    using namespace std;
    
    int main()
    {
    #ifndef ONLINE_JUDGE
            freopen("in.txt","r",stdin);
            freopen("out.txt","w",stdout);
    #endif
    
        int word_size[256];
        int line_cnt = 0;
        vector<string> all[1024];
        string in_line;
        memset(word_size, 0, sizeof(word_size));
        while(getline(cin, in_line))
        {
            int word_cnt = 0;
            string temp;
            vector<string> line;
            stringstream ss(in_line);
            while(ss >> temp)
            {
                int len = temp.size();
                line.push_back(temp);
                word_size[word_cnt] = max(word_size[word_cnt], len);
                word_cnt++;
            }
            all[line_cnt++] = line;
        }
        for(int i = 0; i<line_cnt; i++)
        {
            for(int j = 0; j<all[i].size(); j++)
            {
                cout << all[i][j];
                if(j==all[i].size()-1)
                    break;
                int siz = (int)all[i][j].size();
                for(int k = 0; k < word_size[j]-siz; k++)
                    cout << " ";
                cout << " ";
            }
            cout << endl;
        }
        return 0;
    }


  • 相关阅读:
    Ubuntu下Nginx安装
    vi基本状态
    07. 背景图片距离
    06. 用css实现三角形
    Leetcode刷题 (二)
    Leetcode刷题 (一)
    目标检测中的AP计算
    python 引用(import)文件夹下的py文件
    git 上传和克隆文件
    Windows系统下Pytorch与python版本不匹配导致模块包导入错误
  • 原文地址:https://www.cnblogs.com/kunsoft/p/5312798.html
Copyright © 2020-2023  润新知