• ZOJ 2750 Idiomatic Phrases Game(Dijkstra)


    题目链接

    Idiomatic Phrases Game

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.

    Input

    The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.

    Output

    One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.

    Sample Input

    5
    5 12345978ABCD2341
    5 23415608ACBD3412
    7 34125678AEFD4123
    15 23415673ACC34123
    4 41235673FBCD2156
    2
    20 12345678ABCD
    30 DCBF5432167D
    0
    

    Sample Output

    17
    -1

    题意:Tom在玩一种成语接龙的游戏,他必须选词语,必须前一个词语的最后一个汉字跟后一个词语的第一个汉字相同。每个词语至少有3个汉字,每个汉字包含4位16进制数,找到下一个词语所需时间T。

    分析:设每个词语代表一个顶点,如果第i个顶点最后一个汉字跟第j个顶点第一个汉字相同,就添加i到j的一条有向边,权值为第i个词语找到下个词语的时间

     图的问题难点还是在转化

    AC代码:

    #include <iostream>
    #include <cstdio>
    #include <map>
    #include <string>
    #include <cstring>
    using namespace std;
    const int N=1010;
    const int inf = 0x3f3f3f3f;
    struct node{
        int t;
        string s;
    }str[N];
    int n, cnt;
    map<string, int> q;
    int e[N][N], dis[N];
    bool vis[N];
    void init(){
        for(int i = 1; i < N; i++){
            for(int j = 1; j < N; j++){
                if(i == j) e[i][j] = 0;
                else e[i][j] = inf;
            }
        }
    }
    void Dij(int st){
        memset(vis, false, sizeof(vis));
        vis[st] = true;
        for(int i =1 ; i <= n; i++){
            dis[i] = e[st][i];
        }
        for(int i = 1;i < n; i++){
            int minn = inf, u;
            for(int j = 1; j <= n; j++){
                if(minn > dis[j] && !vis[j]){
                    minn = dis[j];
                    u=j;
                }
            }
            if(minn == inf) break;
            vis[u] = true;
            for(int j = 1;j <= n; j++){
                if(dis[j] > dis[u] + e[u][j]){
                    dis[j] = dis[u] + e[u][j];
                }
            }
        }
    }
    int main(){
        #ifdef ONLINE_JUDGE
        #else
            freopen("in.txt", "r", stdin);
        #endif //ONLINE_JUDGE
        while(cin>>n && n){
            cnt = 0;
            init();
            for(int i = 1; i <= n; i++){
                cin>>str[i].t>>str[i].s;
            }
            for(int i = 1; i <= n; i++){
                string s1 = str[i].s.substr(str[i].s.size()-4, str[i].s.size());
                for(int j = 1; j <= n; j++){
                    if(i == j) continue;
                    string s2 = str[j].s.substr(0, 4);
                    if(s1 == s2) {
                        e[i][j] = str[i].t;
                    }
                }
            }
            Dij(1);
            if(dis[n] == inf) cout<<-1<<endl;
            else cout<<dis[n]<<endl;
        }
        return 0;
    }

  • 相关阅读:
    APDU:APDU常用指令
    其他:IntelliJ IDEA设置运行内存
    Linux:获取Linux离线postgresql数据库安装包并部署
    资源:Postgresql数据库下载路径
    免费版:Xshell和Xftp下载路径
    Raspberry Pi:树莓派开发板配置USB启动系统
    Raspberry Pi:树莓派安装基础系统 Raspberry Pi(树莓派系统)
    Raspberry Pi:树莓派安装Kali2021新版本
    Docker:虚拟机挂起后,再启动docker容器连接失败
    Docker:docker搭建redis一主多从集群(配置哨兵模式)
  • 原文地址:https://www.cnblogs.com/kun-/p/9758616.html
Copyright © 2020-2023  润新知