• POJ 3268 Silver Cow Party (最短路)


    Silver Cow Party
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 10147   Accepted: 4497

    Description

    One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

    Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

    Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

    Input

    Line 1: Three space-separated integers, respectively: NM, and X 
    Lines 2..M+1: Line i+1 describes road i with three space-separated integers: AiBi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

    Output

    Line 1: One integer: the maximum of time any one cow must walk.

    Sample Input

    4 8 2
    1 2 4
    1 3 2
    1 4 7
    2 1 1
    2 3 5
    3 1 2
    3 4 4
    4 2 3

    Sample Output

    10

    Hint

    Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

    Source

     
     
     
    练习模板用的。
    用原图和逆图分别用一次单源最短路。
     
    Dijkstra算法
    //============================================================================
    // Name        : POJ.cpp
    // Author      : 
    // Version     :
    // Copyright   : Your copyright notice
    // Description : Hello World in C++, Ansi-style
    //============================================================================
    
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    const int MAXN=1010;
    const int INF=0x3f3f3f3f;
    bool vis[MAXN];
    void Dijkstra(int cost[][MAXN],int lowcost[],int n,int beg)
    {
        for(int i=1;i<=n;i++)
        {
            lowcost[i]=INF;
            vis[i]=false;
        }
        lowcost[beg]=0;
        for(int j=0;j<n;j++)
        {
            int k=-1;
            int Min=INF;
            for(int i=1;i<=n;i++)
                if(!vis[i]&&lowcost[i]<Min)
                {
                    Min=lowcost[i];
                    k=i;
                }
            if(k==-1)break;
            vis[k]=true;
            for(int i=1;i<=n;i++)
                if(!vis[i]&&lowcost[k]+cost[k][i]<lowcost[i])
                    lowcost[i]=lowcost[k]+cost[k][i];
        }
    }
    int dist1[MAXN];
    int dist2[MAXN];
    int cost[MAXN][MAXN];
    int main()
    {
    //    freopen("in.txt","r",stdin);
    //    freopen("out.txt","w",stdout);
        int N,M,X;
        int u,v,w;
        while(scanf("%d%d%d",&N,&M,&X)==3)
        {
            for(int i=1;i<=N;i++)
                for(int j=1;j<=N;j++)
                {
                    if(i==j)cost[i][j]=0;
                    else cost[i][j]=INF;
                }
            while(M--)
            {
                scanf("%d%d%d",&u,&v,&w);
                cost[u][v]=min(cost[u][v],w);
            }
            Dijkstra(cost,dist1,N,X);
            for(int i=1;i<=N;i++)
                for(int j=1;j<i;j++)
                    swap(cost[i][j],cost[j][i]);
            Dijkstra(cost,dist2,N,X);
            int ans=0;
            for(int i=1;i<=N;i++)
                ans=max(ans,dist1[i]+dist2[i]);
            printf("%d\n",ans);
        }
        return 0;
    }
     
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    MSDN Visual系列:在SharePoint开发环境中配置CAML语法的智能感知
    学习SharePoint你需要什么?
    MSDN Visual系列:用WSSv3中的SPGridView控件来显示数据
    关于DataFormWebPart中CreatedModifiedInfo信息的分开使用
    MSDN Visual系列:在WSSv3中编程方式激活单个文档库的审核功能
    MOSS 2007基础:部署自定义WebPart
    MSDN Visual系列:编程激活SharePoint网站集的审计功能
    升级SharePoint数据库到SQL Server 2005的一点心得
    一个集WF/WCF/Silverlight/SharePoint技术于一身的东西
    MSDN Visual系列:WSSv3之权限提升
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3138233.html
Copyright © 2020-2023  润新知