• HDU 3605 Escape(最大流)


    Escape

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2523    Accepted Submission(s): 691


    Problem Description
    2012 If this is the end of the world how to do? I do not know how. But now scientists have found that some stars, who can live, but some people do not fit to live some of the planet. Now scientists want your help, is to determine what all of people can live in these planets.
     
    Input
    More set of test data, the beginning of each data is n (1 <= n <= 100000), m (1 <= m <= 10) n indicate there n people on the earth, m representatives m planet, planet and people labels are from 0. Here are n lines, each line represents a suitable living conditions of people, each row has m digits, the ith digits is 1, said that a person is fit to live in the ith-planet, or is 0 for this person is not suitable for living in the ith planet.
    The last line has m digits, the ith digit ai indicates the ith planet can contain ai people most..
    0 <= ai <= 100000
     
    Output
    Determine whether all people can live up to these stars
    If you can output YES, otherwise output NO.
     
    Sample Input
    1 1 1 1 2 2 1 0 1 0 1 1
     
    Sample Output
    YES NO
     
    Source
     
    Recommend
    lcy
     
     
     
    这题一看题目是很简单的最大流。
    但是数据好大,试了很多模板,都是TLE。
     
    后来发现可以合并点,
    因为m<=10.
    所以用二进制记录。
    在n个点中,如果是一样的就合并。
    这样最多是1024+m+2个点。
     
     
    但是这题还是很坑。。。。在HDU上用G++交无论如何都是TLE的。直接读入数据输出都是TLE.
    改成C++就AC了。。。
     
     
    //============================================================================
    // Name        : HDU.cpp
    // Author      : 
    // Version     :
    // Copyright   : Your copyright notice
    // Description : Hello World in C++, Ansi-style
    //============================================================================
    
    #include <iostream>
    #include <string.h>
    #include <algorithm>
    #include <stdio.h>
    using namespace std;
    
    const int MAXN=100110;
    const int MAXM=4000110;
    const int INF=0x3f3f3f3f;
    struct Node
    {
        int to,next,cap;
    }edge[MAXM];
    int tol;
    int head[MAXN];
    int gap[MAXN],dis[MAXN],pre[MAXN],cur[MAXN];
    void init()
    {
        tol=0;
        memset(head,-1,sizeof(head));
    }
    void addedge(int u,int v,int w,int rw=0)
    {
        edge[tol].to=v;edge[tol].cap=w;edge[tol].next=head[u];head[u]=tol++;
        edge[tol].to=u;edge[tol].cap=rw;edge[tol].next=head[v];head[v]=tol++;
    }
    int sap(int start,int end,int nodenum)
    {
        memset(dis,0,sizeof(dis));
        memset(gap,0,sizeof(gap));
        memcpy(cur,head,sizeof(head));
        int u=pre[start]=start,maxflow=0,aug=-1;
        gap[0]=nodenum;
        while(dis[start]<nodenum)
        {
            loop:
            for(int  &i=cur[u];i!=-1;i=edge[i].next)
            {
                int v=edge[i].to;
                if(edge[i].cap&&dis[u]==dis[v]+1)
                {
                    if(aug==-1||aug>edge[i].cap)
                        aug=edge[i].cap;
                    pre[v]=u;
                    u=v;
                    if(v==end)
                    {
                        maxflow+=aug;
                        for(u=pre[u];v!=start;v=u,u=pre[u])
                        {
                            edge[cur[u]].cap-=aug;
                            edge[cur[u]^1].cap+=aug;
                        }
                        aug=-1;
                    }
                    goto loop;
                }
            }
            int mindis=nodenum;
            for(int i=head[u];i!=-1;i=edge[i].next)
            {
                int v=edge[i].to;
                if(edge[i].cap&&mindis>dis[v])
                {
                    cur[u]=i;
                    mindis=dis[v];
                }
            }
            if((--gap[dis[u]])==0)break;
            gap[dis[u]=mindis+1]++;
            u=pre[u];
        }
        return maxflow;
    }
    
    int num[1025];
    int a[11];
    int bit[11];
    
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
        bit[0]=1;
        for(int i=1;i<=10;i++)bit[i]=bit[i-1]*2;
        int n,m;
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            init();
            memset(num,0,sizeof(num));
            for(int i=1;i<=n;i++)
            {
                int tmp=0;
                for(int j=0;j<m;j++){scanf("%d",&a[j]);tmp+=a[j]*bit[j];}
                num[tmp]++;
            }
            int start=0,end=1024+m+1,nodenum=2014+m+2;
            for(int i=0;i<1024;i++)
            {
                if(num[i]==0)continue;
                addedge(start,i+1,num[i]);
                for(int j=0;j<10;j++)
                    if(i&bit[j] )
                        addedge(i+1,1024+j+1,INF);
            }
    
            int tmp;
            for(int i=1;i<=m;i++)
            {
                scanf("%d",&tmp);
                addedge(i+1024,end,tmp);
            }
    
            if(sap(start,end,nodenum)==n)printf("YES\n");
            else printf("NO\n");
        }
        return 0;
    }
     
     
     
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    设计模式学习(十二) 责任链模式
    设计模式学习(十一) 享元模式
    设计模式学习(十) 外观模式
    设计模式学习(九) 装饰模式
    设计模式学习(八) 组合模式
    设计模式学习(七) 桥接模式
    设计模式学习(六) 代理模式
    设计模式学习(五) 适配器模式
    设计模式学习(四) 原型模型
    设计模式(三) 建造者模式
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3056675.html
Copyright © 2020-2023  润新知