• HDU 4461 The Power of Xiangqi 第37届ACM/ICPC杭州赛区I题 (水题)


    The Power of Xiangqi

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 13    Accepted Submission(s): 6


    Problem Description

    Xiangqi is one of the most popular two-player board games in China. The game represents a battle between two armies with the goal of capturing the enemy’s “general” piece.
    Now we introduce some basic rules of Xiangqi. Xiangqi is played on a 10×9 board and the pieces are placed on the intersections (points). There are two groups of pieces marked by black or red Chinese characters, belonging to the two players separately. During the game, each player in turn moves one piece from the point it occupies to another point. No two pieces can occupy the same point at the same time. A piece can be moved onto a point occupied by an enemy piece, in which case the enemy piece is "captured" and removed from the board. When the general is in danger of being captured by the enemy player on the enemy player’s next move, the enemy player is said to have "delivered a check". If the general's player can make no move to prevent the general's capture by next enemy move, the situation is called “checkmate”.
    Each player has 7 kinds of pieces in this game. Their names, offense power and symbol letters are shown in the table below:



    Now show you the pieces of red player and black player, you are going to find out which player has the larger total offense power. Since Ma and Pao working together can have good effect, if a player has no Ma or no Pao, or has neither, his total offense power will be decreased by one. But the total offense power can't be decreased to zero, it is at least one.
     
    Input
    The first line is an integer T ( T <= 20) meaning there are T test cases.
    For each test case: The first line shows which pieces the red player has. It begins with an integer n ( 0 < n <= 16) meaning the number of pieces.
    Then n letters follows, all separated by one or more blanks. Each letter is a symbol letter standing for a piece, as shown in the table above.
    The second line describes the situation of the black player, in the same format as the first line.
     
    Output
    For each test case, if the red player has more offense power, then print "red". If the black player has more offense power, then print "black". If there is a tie, print "tie".
     
    Sample Input
    3 2 A B 2 A B 7 A A B C D D F 7 A A B B C C F 5 A A B B F 3 A B F
     
    Sample Output
    tie black red
     
    Source
     
     
    此题真的非常水啊。。。现场赛17min才有人A,,,很奇怪。。。
    不解释。。。。。水得不能再水了。。。
     
    //============================================================================
    // Name        : HDU4461.cpp
    // Author      : 
    // Version     :
    // Copyright   : Your copyright notice
    // Description : Hello World in C++, Ansi-style
    //============================================================================
    
    #include <iostream>
    #include <stdio.h>
    #include <algorithm>
    #include <string.h>
    #include <math.h>
    using namespace std;
    
    int main() {
        int T;
        int n;
        char str[10];
        scanf("%d",&T);
        while(T--)
        {
            int sum1=0,sum2=0;
            bool ma=false,pao=false;
            scanf("%d",&n);
            while(n--)
            {
                scanf("%s",str);
                if(str[0]=='A')sum1+=16;
                else if(str[0]=='B')sum1+=7,ma=true;
                else if(str[0]=='C')sum1+=8,pao=true;
                else if(str[0]=='D'||str[0]=='E')sum1+=1;
                else if(str[0]=='F')sum1+=2;
                else sum1+=3;
            }
            if((!ma)||(!pao))
                if(sum1>1)sum1-=1;
            ma=false,pao=false;
            scanf("%d",&n);
            while(n--)
            {
                scanf("%s",str);
                if(str[0]=='A')sum2+=16;
                else if(str[0]=='B')sum2+=7,ma=true;
                else if(str[0]=='C')sum2+=8,pao=true;
                else if(str[0]=='D'||str[0]=='E')sum2+=1;
                else if(str[0]=='F')sum2+=2;
                else sum2+=3;
            }
            if((!ma)||(!pao))
                    if(sum2>1)sum2-=1;
            if(sum1==sum2)printf("tie\n");
            else if(sum1>sum2)printf("red\n");
            else printf("black\n");
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    MySQL主主同步方案
    Mysql增量备份与恢复
    配置合适的存储引擎
    基于Amoeba读写分离
    部署myaql主从异步复制
    MySQL完全备份操作
    echo 命令详解
    ELK 基本部署
    zabbix 简介
    基于 Git Tag 发布及回滚代码
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2761044.html
Copyright © 2020-2023  润新知