• HDU 4445 Crazy Tank (简单物理题,枚举)


    Crazy Tank

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1835    Accepted Submission(s): 265


    Problem Description
    Crazy Tank was a famous game about ten years ago. Every child liked it. Time flies, children grow up, but the memory of happy childhood will never go.

    Now you’re controlling the tank Laotu on a platform which is H meters above the ground. Laotu is so old that you can only choose a shoot angle(all the angle is available) before game start and then any adjusting is not allowed. You need to launch N cannonballs and you know that the i-th cannonball’s initial speed is Vi.
    On the right side of Laotu There is an enemy tank on the ground with coordination(L1, R1) and a friendly tank with coordination(L2, R2). A cannonball is considered hitting enemy tank if it lands on the ground between [L1,R1] (two ends are included). As the same reason, it will be considered hitting friendly tank if it lands between [L2, R2]. Laotu's horizontal coordination is 0.
    The goal of the game is to maximize the number of cannonballs which hit the enemy tank under the condition that no cannonball hits friendly tank.
    The g equals to 9.8.
     
    Input
    There are multiple test case.
    Each test case contains 3 lines.
    The first line contains an integer N(0≤N≤200), indicating the number of cannonballs to be launched.
    The second line contains 5 float number H(1≤H≤100000), L1, R1(0<L1<R1<100000) and L2, R2(0<L2<R2<100000). Indicating the height of the platform, the enemy tank coordinate and the friendly tank coordinate. Two tanks may overlap.
    The third line contains N float number. The i-th number indicates the initial speed of i-th cannonball.
    The input ends with N=0.
     
    Output
    For each test case, you should output an integer in a single line which indicates the max number of cannonballs hit the enemy tank under the condition that no cannonball hits friendly tank.
     
    Sample Input
    2 10 10 15 30 35 10.0 20.0 2 10 35 40 2 30 10.0 20.0 0
     
    Sample Output
    1 0
    Hint
    In the first case one of the best choices is that shoot the cannonballs parallelly to the horizontal line, then the first cannonball lands on 14.3 and the second lands on 28.6. In the second there is no shoot angle to make any cannonball land between [35,40] on the condition that no cannonball lands between [2,30].
     
    Source
     
    Recommend
    zhuyuanchen520
     
     
    对角度进行枚举,求出答案。
    #include <stdio.h>
    #include <iostream>
    #include <math.h>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    const int MAXN=220;
    const double PI=acos(-1.0);
    const double g=9.8;
    double v[MAXN];
    double  L1,R1,L2,R2;
    double H;
    int n;
    
    int ff(double x)//角度为x;
    {
        int ret=0;
        for(int i=0;i<n;i++)
        {
            double Vy0=v[i]*sin(x);
            double Vx0=v[i]*cos(x);
            double Vy=sqrt(2*g*H+Vy0*Vy0);
            double t=(Vy-Vy0)/g;
            double d=Vx0*t;
            if(d>=L2&&d<=R2)return 0;
            if(d>=L1&&d<=R1)ret++;
        }
        return ret;
    }
    int main()
    {
        while(scanf("%d",&n) == 1 && n)
        {
            scanf("%lf%lf%lf%lf%lf",&H,&L1,&R1,&L2,&R2);
            for(int i=0;i<n;i++)
              scanf("%lf",&v[i]);
            double add=PI/1000;
            int ans=0;
            for(double x=-PI/2;x<=PI/2;x+=add)
              ans=max(ans,ff(x));
            printf("%d\n",ans);
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    深入理解Java8中Stream的实现原理
    RocketMQ的顺序消费和事务消费
    Java 性能调优小技巧
    类加载机制基础
    十大经典排序算法
    分布式锁的几种常用实现方式
    python之接口开发
    python之urllib模块和requests模块
    python之time模块和hashlib模块
    python之os和sys模块的区别
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2754420.html
Copyright © 2020-2023  润新知