• HDU 1072 Nightmare (bfs)


    Nightmare

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 4504    Accepted Submission(s): 2272


    Problem Description
    Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

    Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

    Here are some rules:
    1. We can assume the labyrinth is a 2 array.
    2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
    3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
    4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
    5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
    6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
    There are five integers which indicate the different type of area in the labyrinth:
    0: The area is a wall, Ignatius should not walk on it.
    1: The area contains nothing, Ignatius can walk on it.
    2: Ignatius' start position, Ignatius starts his escape from this position.
    3: The exit of the labyrinth, Ignatius' target position.
    4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
     
    Output
    For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
     
    Sample Input
    3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
     
    Sample Output
    4 -1 13
     
    Author
    Ignatius.L
     
     
    bfs,搜索。
    注意判重。
    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<algorithm>
    #include<queue>
    using namespace std;
    
    const int MAXN=10;
    int g[MAXN][MAXN];
    int move[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
    int n,m;
    bool used[MAXN][MAXN][10];
    struct Node
    {
        int x,y;
        int t;
        int tolTime;
    };
    
    int sx,sy;//起点
    int ex,ey;
    int bfs()
    {
        queue<Node>que;
        memset(used,false,sizeof(used));
        while(!que.empty())que.pop();
        Node tmp;
        tmp.x=sx;
        tmp.y=sy;
        tmp.t=6;
        used[sx][sy][6]=true;
        tmp.tolTime=0;
        que.push(tmp);
        Node now;
        while(!que.empty())
        {
            tmp=que.front();
            que.pop();
            if(tmp.x==ex&&tmp.y==ey)return tmp.tolTime;
            if(tmp.t==1)continue;
            for(int i=0;i<4;i++)
            {
                int xx=tmp.x+move[i][0];
                int yy=tmp.y+move[i][1];
                if(xx<0||xx>=n||yy<0||yy>=m)continue;
                if(g[xx][yy]==0)continue;
                now.x=xx;
                now.y=yy;
                now.t=tmp.t-1;
                now.tolTime=tmp.tolTime+1;
                if(g[xx][yy]==4)now.t=6;
                if(used[xx][yy][now.t])continue;
                else used[xx][yy][now.t]=true;//判重
                que.push(now);
            }
        }
        return -1;
    }
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
        int T;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d",&n,&m);
            for(int i=0;i<n;i++)
              for(int j=0;j<m;j++)
              {
                  scanf("%d",&g[i][j]);
                  if(g[i][j]==2)sx=i,sy=j;
                  if(g[i][j]==3)ex=i,ey=j;
              }
            printf("%d\n",bfs());
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    angularjs-ngTable select filter
    angularjs-ngModel 控制页面的宽度
    angularjs-ngModel传值问题
    Jquery中去除左右空格
    Python命令行下退格、删除、方向键乱码问题解决
    linux解压.tar.xz的方法
    python OS模块详解
    pip is configured with locations that require TLS/SSL, however the ssl module in Python is not
    centos7 python2.7.5 升级python3.6.4
    使用mkfs.ext4格式化大容量磁盘
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2743821.html
Copyright © 2020-2023  润新知