• SGU 495 Kids and Prizes (概率DP)


    495. Kids and Prizes

    Time limit per test: 0.5 second(s)
    Memory limit: 262144 kilobytes
    input: standard
    output: standard




    ICPC (International Cardboard Producing Company) is in the business of producing cardboard boxes. Recently the company organized a contest for kids for the best design of a cardboard box and selected M winners. There are Nprizes for the winners, each one carefully packed in a cardboard box (made by the ICPC, of course). The awarding process will be as follows:

    • All the boxes with prizes will be stored in a separate room.
    • The winners will enter the room, one at a time.
    • Each winner selects one of the boxes.
    • The selected box is opened by a representative of the organizing committee.
    • If the box contains a prize, the winner takes it.
    • If the box is empty (because the same box has already been selected by one or more previous winners), the winner will instead get a certificate printed on a sheet of excellent cardboard (made by ICPC, of course).
    • Whether there is a prize or not, the box is re-sealed and returned to the room.

    The management of the company would like to know how many prizes will be given by the above process. It is assumed that each winner picks a box at random and that all boxes are equally likely to be picked. Compute the mathematical expectation of the number of prizes given (the certificates are not counted as prizes, of course).

    Input

    The first and only line of the input file contains the values of N and M ().

    Output

    The first and only line of the output file should contain a single real number: the expected number of prizes given out. The answer is accepted as correct if either the absolute or the relative error is less than or equal to 10-9.

    Example(s)
    sample input
    sample output
    5 7
    
    3.951424
    
    sample input
    sample output
    4 3
    
    2.3125
    




    此题算是简单的概率DP吧。

    但是一时没有想到就感觉很困难了。

    两种解法。

    详细看代码:

    /*
    SGU 495
    题意:n个盒子里装有礼物,m个人随机选择礼物,选完之后空盒子放回
    问选中的礼物数的期望。
    
    m个人是独立的。
    对于每个礼物不被人选中的概率为((n-1)/n)^m
    那么不被选中的礼物数的期望就是 n*((n-1)/n)^m
    所以答案就是  n-n*((n-1)/n)^m;
    
    */
    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<math.h>
    using namespace std;
    int main()
    {
        int n,m;
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            double p=(double)(n-1)/n;
            double ans=n-n*pow(p,m);
            printf("%.10lf\n",ans);
        }
        return 0;
    }
    /*
    SGU 495
    */
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    #include<algorithm>
    #include<math.h>
    using namespace std;
    const int MAXN=100010;
    double dp[MAXN];//dp[i]表示第i个人得到礼物的概率
    
    int main()
    {
        int n,m;
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            dp[1]=1;
            for(int i=2;i<=m;i++)
            {//第i个人得到礼物的概率:假如第i-1个人没有得到礼物,那么i得到礼物的概率和i-1一样。
                //假如第i-1个人得到了礼物,那么i得到礼物的概率是i-1得到礼物概率减去1/n
                dp[i]=(1-dp[i-1])*dp[i-1]+dp[i-1]*(dp[i-1]-1.0/n);
            }
            double ans=0;
            for(int i=1;i<=m;i++)ans+=dp[i];
            printf("%.10lf\n",ans);
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    keepAliveTime为0以及队列太小导致ThreadPoolExecutor不断创建新线程
    Python str方法
    Python 复制与赋值
    Python 使用pypi镜像源加速第三方库在线安装
    Python ez_setup.py安装错误
    Tools psr
    Python 列表生成试中的if,if else
    Python 执行方法shift+enter
    Python
    DOS 切换文件夹
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2711437.html
Copyright © 2020-2023  润新知