• HDU 3853 LOOPS(概率DP)


    LOOPS

    Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
    Total Submission(s): 649    Accepted Submission(s): 267


    Problem Description
    Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

    Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.

    The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
    At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.




     
    Input
    The first line contains two integers R and C (2 <= R, C <= 1000).

    The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

    It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

    You may ignore the last three numbers of the input data. They are printed just for looking neat.

    The answer is ensured no greater than 1000000.

    Terminal at EOF


     
    Output
    A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

     
    Sample Input
    2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
     
    Sample Output
    6.000
     
    Source
     
    Recommend
    chenyongfu
     
     
    比较简单的概率DP了。很容易写出方程去递推出答案。
    注意特殊情况要判断下。
    /*
    HDU 3853
    
    解析:
    设dp[i][j]表示(i,j)到(R,C)需要消耗的能量
    则:
    dp[i][j]=p1[i][j]*dp[i][j]+p2[i][j]*dp[i][j+1]+p3[i][j]*dp[i+1][j]+2;
    化简得到:
    dp[i][j]=p2[i][j]*dp[i][j+1]/(1-p1[i][j])+p3[i][j]*dp[i+1][j]/(1-p1[i][j])+2/(1-p1[i][j]);
    注意一种情况就是p1[i][j]==1的情况。
    题目只是保证答案小于1000000.但是有的点可能永远都不可能到达的。
    所以这样的点出现p1[i][j]是允许的。
    否则就会WA了。
    */
    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    #include<math.h>
    using namespace std;
    const int MAXN=1010;
    const double eps=1e-5;
    double dp[MAXN][MAXN];
    double p1[MAXN][MAXN];
    double p2[MAXN][MAXN];
    double p3[MAXN][MAXN];
    
    int main()
    {
        int R,C;
        while(scanf("%d%d",&R,&C)!=EOF)
        {
            for(int i=1;i<=R;i++)
              for(int j=1;j<=C;j++)
                scanf("%lf%lf%lf",&p1[i][j],&p2[i][j],&p3[i][j]);
            dp[R][C]=0;
            for(int i=R;i>=1;i--)
              for(int j=C;j>=1;j--)
              {
                  if(i==R&&j==C)continue;
                  if(fabs(1-p1[i][j])<eps)continue;
                  dp[i][j]=p2[i][j]/(1-p1[i][j])*dp[i][j+1]+p3[i][j]/(1-p1[i][j])*dp[i+1][j]+2/(1-p1[i][j]);
              }
            printf("%.3lf\n",dp[1][1]);
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    oracle 函数
    Oracle 语句
    递归算法算出某个目录下所有目录和文件
    static
    递归算法
    JVM/JDK/JRE
    java跨平台原理
    .NET 未在本地计算机上注册“Microsoft.Jet.OLEDB.4.0”
    JS 判断对象是否为空
    html网页打印A4样式
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2711140.html
Copyright © 2020-2023  润新知