• ZOJ 3329 One Person Game(概率DP,求期望)


    One Person Game

    Time Limit: 1 Second      Memory Limit: 32768 KB      Special Judge

    There is a very simple and interesting one-person game. You have 3 dice, namely Die1, Die2 and Die3. Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1, K2, K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

    1. Set the counter to 0 at first.
    2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
    3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

    Calculate the expectation of the number of times that you cast dice before the end of the game.

    Input

    There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers n, K1, K2, K3, a, b, c (0 <= n <= 500, 1 < K1, K2, K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

    Output

    For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

    Sample Input

    2
    0 2 2 2 1 1 1
    0 6 6 6 1 1 1
    

    Sample Output

    1.142857142857143
    1.004651162790698
    

    Author: CAO, Peng
    Source: The 7th Zhejiang Provincial Collegiate Programming Contest

    本题通过代换系数,化简后求系数。

    一般形成环的用高斯消元法求解。但是此题都是和dp[0]相关。所有可以分离出系数。

    /*
    ZOJ 3329
    题意:有三个骰子,分别有k1,k2,k3个面。
    每次掷骰子,如果三个面分别为a,b,c则分数置0,否则加上三个骰子的分数之和。
    当分数大于n时结束。求游戏的期望步数。初始分数为0
    
    设dp[i]表示达到i分时到达目标状态的期望,pk为投掷k分的概率,p0为回到0的概率
    则dp[i]=∑(pk*dp[i+k])+dp[0]*p0+1;
    都和dp[0]有关系,而且dp[0]就是我们所求,为常数
    设dp[i]=A[i]*dp[0]+B[i];
    代入上述方程右边得到:
    dp[i]=∑(pk*A[i+k]*dp[0]+pk*B[i+k])+dp[0]*p0+1
         =(∑(pk*A[i+k])+p0)dp[0]+∑(pk*B[i+k])+1;
         明显A[i]=(∑(pk*A[i+k])+p0)
         B[i]=∑(pk*B[i+k])+1
         先递推求得A[0]和B[0].
         那么  dp[0]=B[0]/(1-A[0]);
    */
    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    
    double A[600],B[600];
    double p[100];
    int main()
    {
        int T;
        int k1,k2,k3,a,b,c;
        int n;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d%d%d%d%d%d",&n,&k1,&k2,&k3,&a,&b,&c);
            double p0=1.0/k1/k2/k3;
            memset(p,0,sizeof(p));
            for(int i=1;i<=k1;i++)
              for(int j=1;j<=k2;j++)
                for(int k=1;k<=k3;k++)
                  if(i!=a||j!=b||k!=c)
                    p[i+j+k]+=p0;
            memset(A,0,sizeof(A));
            memset(B,0,sizeof(B));
            for(int i=n;i>=0;i--)
            {
                A[i]=p0;B[i]=1;
                for(int j=1;j<=k1+k2+k3;j++)
                {
                    A[i]+=A[i+j]*p[j];
                    B[i]+=B[i+j]*p[j];
                }
            }
            printf("%.16lf\n",B[0]/(1-A[0]));
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    Linux 查看磁盘读写速度IO使用情况
    Kubernete安装
    jenkins问题解决
    Jenkins用HTTP Request Plugin插件进行网站的监控/加探针(运维监控)
    golang信号signal的处理
    修改docker仓库资源的地址
    centos7修改hostname
    同步CentOS时间
    CentOs查那个目录占空间大
    CentOS7主机名的修改
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2710648.html
Copyright © 2020-2023  润新知