• ZOJ 3207 80ers' Memory(水题)


    80ers' Memory

    Time Limit: 1 Second      Memory Limit: 32768 KB

    I guess most of us are so called 80ers, which means that we were born in the 1980's. This group of people shared a lot of common memories. For example, the Saint Seiya, the YoYo ball, the Super Mario, and so on. Do you still remember these?

    Input

    There will be ONLY ONE test case.

    The test case begins with a positive integer N, (N < 100).
    Then there will be N lines each containing a single word describing a keyword of the typical 80ers' memories. Each word consists of letters, [a-zA-Z], numbers, [0-9], and the underline, '_'. The length of each word would be no more than 20.
    Then one line follows with a positive integer K, (K < 100).
    The last part of the test case will be K lines. The i-th line contains the keywords given by the i-th person and starts with a positive integer Ni. Then there will be Ni words separated by white spaces. Each of these words has no more than 20 characters.
    All the words are case sensitive.

    Output

    For each of these K people, you are asked to count the number of typical 80ers' keywords on his/her list and output it in a single line.

    Sample Input

    4
    Saint_Seiya
    YoYo_ball
    Super_Mario
    HuLuWa
    3
    2 Saint_Seiya TiaoFangZi
    1 KTV
    3 HuLuWa YOYO_BALL YoYo_ball
    

    Sample Output

    1
    0
    2
    

    Author: GAO, Fei
    Source: The 6th Zhejiang Provincial Collegiate Programming Contest

    map秒过了。。。

    水题。。

    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    #include<string>
    #include<algorithm>
    #include<map>
    using namespace std;
    map<string,int>mp;
    int main()
    {
        int n,k;
        int m;
        string str;
        while(scanf("%d",&n)!=EOF)
        {
            mp.clear();
            while(n--)
            {
                cin>>str;
                if(mp[str]==0)mp[str]=1;
            }
            int ans;
            scanf("%d",&k);
            while(k--)
            {
                scanf("%d",&m);
                ans=0;
                while(m--)
                {
                    cin>>str;
                    ans+=mp[str];
                }
                printf("%d\n",ans);
            }
        }
        return 0;
    }
  • 相关阅读:
    Windows10 iis10 arr webfarm
    两个command的疑惑
    关于controller和apicontroller的跨域实现过滤器的不同
    抽象工厂
    c# 字体库跨域解决
    c# 父类的引用指向子类的实例
    垂直居中
    扇形导航
    2D变换
    京东放大镜效果
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2706130.html
Copyright © 2020-2023  润新知