• POJ 3264 Balanced Lineup(RMQ)


    Balanced Lineup
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 24349   Accepted: 11348
    Case Time Limit: 2000MS

    Description

    For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

    Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

    Input

    Line 1: Two space-separated integers, N and Q.
    Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
    Lines N+2..N+Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

    Output

    Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

    Sample Input

    6 3
    1
    7
    3
    4
    2
    5
    1 5
    4 6
    2 2

    Sample Output

    6
    3
    0

    Source

     
    #include<stdio.h>
    #include<iostream>
    #include<math.h>
    #include<string.h>
    using namespace std;
    const int MAXN=50050;
    
    int dpmax[MAXN][20];
    int dpmin[MAXN][20];
    
    void makeMaxRmq(int n,int b[])
    {
        for(int i=0;i<n;i++)
           dpmax[i][0]=b[i];
        for(int j=1;(1<<j)<=n;j++)
          for(int i=0;i+(1<<j)-1<n;i++)
            dpmax[i][j]=max(dpmax[i][j-1],dpmax[i+(1<<(j-1))][j-1]);
    }
    int getMax(int u,int v)
    {
        int k=(int)(log(v-u+1.0)/log(2.0));
        return max(dpmax[u][k],dpmax[v-(1<<k)+1][k]);
    }
    void makeMinRmq(int n,int b[])
    {
        for(int i=0;i<n;i++)
           dpmin[i][0]=b[i];
        for(int j=1;(1<<j)<=n;j++)
          for(int i=0;i+(1<<j)-1<n;i++)
            dpmin[i][j]=min(dpmin[i][j-1],dpmin[i+(1<<(j-1))][j-1]);
    }
    int getMin(int u,int v)
    {
        int k=(int)(log(v-u+1.0)/log(2.0));
        return min(dpmin[u][k],dpmin[v-(1<<k)+1][k]);
    }
    
    int a[MAXN];
    int main()
    {
        int n,Q;
        int u,v;
        while(scanf("%d%d",&n,&Q)!=EOF)
        {
            for(int i=0;i<n;i++)
               scanf("%d",&a[i]);
            makeMaxRmq(n,a);
            makeMinRmq(n,a);
            while(Q--)
            {
                scanf("%d%d",&u,&v);
                u--;
                v--;
                int t1=getMax(u,v);
                int t2=getMin(u,v);
                printf("%d\n",t1-t2);
            }
        }
        return 0;
    }
  • 相关阅读:
    idea 从svn导入项目遇到的错误
    用sql语句处理字符串以逗号截开分别获取值
    tree grid 实现编辑保存然后整体存入数据库
    EasyUI的TreeGrid的json格式,树状图显示问题
    vue.js--菜鸟级入门
    Django3.0知识笔记——WSGI&ASGI是什么?
    open stack
    shell脚本简介及常用文本编辑命令
    shell脚本之变量与运算符
    shell编程之流程控制(for、while、case、break、continue)
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2687220.html
Copyright © 2020-2023  润新知