• POJ 1222 EXTENDED LIGHTS OUT(高斯消元法)


    EXTENDED LIGHTS OUT
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 4669   Accepted: 3073

    Description

    In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.

    The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.

    Note:
    1. It does not matter what order the buttons are pressed.
    2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
    3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
    four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
    Write a program to solve the puzzle.

    Input

    The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

    Output

    For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

    Sample Input

    2
    0 1 1 0 1 0
    1 0 0 1 1 1
    0 0 1 0 0 1
    1 0 0 1 0 1
    0 1 1 1 0 0
    0 0 1 0 1 0
    1 0 1 0 1 1
    0 0 1 0 1 1
    1 0 1 1 0 0
    0 1 0 1 0 0

    Sample Output

    PUZZLE #1
    1 0 1 0 0 1
    1 1 0 1 0 1
    0 0 1 0 1 1
    1 0 0 1 0 0
    0 1 0 0 0 0
    PUZZLE #2
    1 0 0 1 1 1
    1 1 0 0 0 0
    0 0 0 1 0 0
    1 1 0 1 0 1
    1 0 1 1 0 1

    Source

     
     
     
    30个格子,就是30个方程,30个未知数。
    高斯消元法
     
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    #include<math.h>
    #include<algorithm>
    using namespace std;
    
    const int MAXN=40;
    
    //有equ个方程,var个变元。增广矩阵行数为equ,分别为0到equ-1,列数为var+1,分别为0到var.
    int equ,var;
    int a[MAXN][MAXN];//增广矩阵
    int x[MAXN];//解集
    
    
    int  Gauss()
    {
        int i,j,k;
        int max_r;
        int col;
        int temp;
    
        col=0;
        for(k=0;k<equ&&col<var;k++,col++)
        {
            max_r=k;
            for(i=k+1;i<equ;i++)
            {
                if(abs(a[i][col])>abs(a[max_r][col]))max_r=i;
            }
            if(max_r!=k)
            {
                for(j=col;j<var+1;j++)swap(a[k][j],a[max_r][j]);
            }
            if(a[k][col]==0)
            {
                k--;
                continue;
            }
            for(i=k+1;i<equ;i++)
            {
                if(a[i][col]!=0)
                {
                    for(j=col;j<var+1;j++)
                      a[i][j]^=a[k][j];
                }
            }
        }
        for(i=var-1;i>=0;i--)
        {
            x[i]=a[i][var];
            for(j=i+1;j<var;j++)
              x[i]^=(a[i][j]&&x[j]);
        }
        return 0;
    }
    
    void init()
    {
        memset(a,0,sizeof(a));
        equ=30;
        var=30;
        for(int i=0;i<5;i++)
           for(int j=0;j<6;j++)
           {
               int t=i*6+j;
               a[t][t]=1;
               if(i>0)a[(i-1)*6+j][t]=1;
               if(i<4)a[(i+1)*6+j][t]=1;
               if(j>0)a[i*6+j-1][t]=1;
               if(j<5)a[i*6+j+1][t]=1;
           }
    }
    
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
       int T;
       scanf("%d",&T);
       int iCase=0;
       while(T--)
       {
           iCase++;
           init();
           for(int i=0;i<30;i++)scanf("%d",&a[i][30]);
           Gauss();
           printf("PUZZLE #%d",iCase);
           for(int i=0;i<30;i++)
           {
               if(i%6==0)printf("\n%d",x[i]);
               else printf(" %d",x[i]);
           }
           printf("\n");
       }
       return 0;
    }
  • 相关阅读:
    [windows]清除访问共享的用户和密码信息
    Java架构搜集
    jsp、freemarker、velocity对比
    Spring MVC 了解WebApplicationContext中特殊的bean类型
    Web.xml配置详解之context-param
    <context:annotation-config/> 的理解
    使用@Controller注解为什么要配置<mvc:annotation-driven />
    web.xml配置之<context-param>详解
    @WebServlet
    正向代理与反向代理
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2665308.html
Copyright © 2020-2023  润新知