• HDU 3336 Count the string(KMP)


    Count the string

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 2191    Accepted Submission(s): 1038


    Problem Description
    It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
    s: "abab"
    The prefixes are: "a", "ab", "aba", "abab"
    For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
    The answer may be very large, so output the answer mod 10007.
     
    Input
    The first line is a single integer T, indicating the number of test cases.
    For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
     
    Output
    For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
     
    Sample Input
    1 4 abab
     
    Sample Output
    6
     
    Author
    foreverlin@HNU
     
    Source
     
    Recommend
    lcy
     
     
    KMP中next数组的应用。
    #include<stdio.h>
    #include<string.h>
    const int MAXN=200020;
    const int MOD=10007;
    int dp[MAXN];
    char str[MAXN];
    int next[MAXN];
    
    void getNext(char *p)
    {
        int j,k;
        j=0;
        k=-1;
        next[0]=-1;
        int len=strlen(p);
        while(j<len)
        {
            if(k==-1||p[j]==p[k])
            {
                j++;
                k++;
                next[j]=k;
            }
            else k=next[k];
        }
    }
    int main()
    {
        int T;
        int n;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d",&n);
            scanf("%s",&str);
            getNext(str);
            dp[0]=0;
            int ans=0;
            for(int i=1;i<=n;i++)
            {
                dp[i]=dp[next[i]]+1;
                dp[i]%=MOD;
                ans+=dp[i];
                ans%=MOD;
            }
            printf("%d\n",ans);
        }
        return 0;
    }

    这其中dp[i]从1加到n

    dp[i]=dp[next[i]]+1;

  • 相关阅读:
    async源码学习
    js 数组去重
    node通过http.request向其他服务器上传文件
    学习CSS布局
    学习CSS布局
    学习CSS布局
    学习CSS布局
    学习CSS布局
    学习CSS布局
    学习CSS布局
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2663464.html
Copyright © 2020-2023  润新知