• POJ 2063 Investment(完全背包)



     

    Investment
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 5362   Accepted: 1843

    Description

    John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor.
    John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him.
    This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated.
    Assume the following bonds are available:
    Value Annual
    interest
    4000
    3000
    400
    250

    With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200.
    Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

    Input

    The first line contains a single positive integer N which is the number of test cases. The test cases follow.
    The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40).
    The following line contains a single number: the number d (1 <= d <= 10) of available bonds.
    The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

    Output

    For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

    Sample Input

    1
    10000 4
    2
    4000 400
    3000 250

    Sample Output

    14050

    Source

     
     
     
     
     
    这题数据范围很大,比估算的要大很多。
     The value of a bond is always a multiple of $1 000.这句话告诉我们算完全背包的时候,可以把总的钱除于1000,把每种债券的价格也除于1000,这样可以减少时间。
    而且注意的是原来的钱不一定是1000的整数倍的。这点有点坑,而且得到的利息也不是1000的整数倍。
    而且必须把原来的价格和得到的利息记录下来。
    每年做一次完全背包。。
     
    代码1:
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    int f[5000000];
    int c[20],w[20];
    int  fun(int V,int n)
    {
        V/=1000;
        for(int i=0;i<n;i++)
          for(int j=c[i];j<=V;j++)
             f[j]=max(f[j],f[j-c[i]]+w[i]);
        return f[V];
    
    }
    int main()
    {
        int V,p;
        int T;
        int n;
        scanf("%d",&T);
        while(T--)
        {
            memset(f,0,sizeof(f));
            scanf("%d%d",&V,&p);
            scanf("%d",&n);
            for(int i=0;i<n;i++)
            {
                scanf("%d%d",&c[i],&w[i]);
                c[i]/=1000;
            }
            int ans=V;
            for(int i=0;i<p;i++)ans+=fun(ans,n);
            printf("%d\n",ans);
    
        }
        return 0;
    }

    代码2:

    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    int f[5010000];
    int V;
    int c[200],w[200];
    void CompletePack(int cost,int weight)
    {
        for(int v=cost;v<=V;v++)
          f[v]=max(f[v],f[v-cost]+weight);
    }
    int main()
    {
       //freopen("in.txt","r",stdin);
       // freopen("out.txt","w",stdout);
        int T;
        int n;
        scanf("%d",&T);
        int p;
        while(T--)
        {
            scanf("%d%d",&V,&p);
            int tempV=V;
            V/=1000;
            scanf("%d",&n);
            for(int i=0;i<n;i++)
            {
                scanf("%d%d",&c[i],&w[i]);
                c[i]/=1000;
            }
            memset(f,0,sizeof(f));
            for(int i=0;i<n;i++)
               CompletePack(c[i],w[i]);
            int sumtemp=f[V];
            int temp=f[V];
            int temp2=(tempV+temp)/1000;
            //printf("%d %d  %d\n",temp,V,temp2);
           int tt=temp2-V;
            for(int i=1;i<p;i++)
            {
                if(tt>0)
                {
                    for(int j=0;j<n;j++)
                       for(int v=c[j];v<=temp2;v++)
                           f[v]=max(f[v],f[v-c[j]]+w[j]);
                }
                temp+=f[temp2];
                tt=(tempV+temp)/1000-temp2;
                temp2=(tempV+temp)/1000;
              //  printf("%d    %d   %d\n",temp,temp2,V);
            }
            if(p==0)printf("%d\n",tempV);
            else
            printf("%d\n",tempV+temp);
        }
        return 0;
    }
  • 相关阅读:
    Ubuntu下安装、激活并配置Pycharm
    高分辨率下firefox字体和界面自动放大的问题
    Java如何根据IP获取当前定位
    WebSocket介绍和一个简单的聊天室
    java注解处理
    TCP/IP协议三次握手与四次握手流程解析
    mybatis如何做分页处理
    xshell学习笔记
    正交表生成工具 PICT 成对组合覆盖 收藏
    Ready api groovy script 参数化
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2639817.html
Copyright © 2020-2023  润新知