• HDU 1698 Just a Hook(线段树,成段更新)


    Just a Hook

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 9258    Accepted Submission(s): 4510


    Problem Description
    In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



    Now Pudge wants to do some operations on the hook.

    Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
    The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

    For each cupreous stick, the value is 1.
    For each silver stick, the value is 2.
    For each golden stick, the value is 3.

    Pudge wants to know the total value of the hook after performing the operations.
    You may consider the original hook is made up of cupreous sticks.
     
    Input
    The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
    For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
    Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
     
    Output
    For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
     
    Sample Input
    1 10 2 1 5 2 5 9 3
     
    Sample Output
    Case 1: The total value of the hook is 24.
     
    Source
     
    Recommend
    wangye
     
     
     
     
    线段树
     
    主要是更新方法,不能直接更新到底部,要成段更新,加lazy标志位
     
    /*
    HDU 1689
    线段树
    成段更新
    */
    
    
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    #include<iostream>
    using namespace std;
    const int MAXN=100010;
    struct Node
    {
        int l,r;
        int lazy,tag;
        int sum;
    }segTree[MAXN*3];
    void Build(int i,int l,int r)
    {
        segTree[i].l=l;
        segTree[i].r=r;
        segTree[i].lazy=0;
        segTree[i].tag=0;
        if(l==r)
        {
            segTree[i].sum=1;
            return;
        }
        int mid=(l+r)>>1;
        Build(i<<1,l,mid);
        Build((i<<1)|1,mid+1,r);
        segTree[i].sum=segTree[i<<1].sum+segTree[(i<<1)|1].sum;
    }
    void update(int i,int l,int r,int v)
    {
        if(segTree[i].l==l&&segTree[i].r==r)//成段更新
        {
            segTree[i].lazy=1;
            segTree[i].tag=v;
            segTree[i].sum=(r-l+1)*v;
            return;
        }
        int mid=(segTree[i].l+segTree[i].r)>>1;
        if(segTree[i].lazy==1)
        {
            segTree[i].lazy=0;
            update(i<<1,segTree[i].l,mid,segTree[i].tag);
            update((i<<1)|1,mid+1,segTree[i].r,segTree[i].tag);
            segTree[i].tag=0;
        }
        if(r<=mid) update(i<<1,l,r,v);
        else if(l>mid)update((i<<1)|1,l,r,v);
        else
        {
            update(i<<1,l,mid,v);
            update((i<<1)|1,mid+1,r,v);
        }
        segTree[i].sum=segTree[i<<1].sum+segTree[(i<<1)|1].sum;
    }
    int main()
    {
          //  freopen("in.txt","r",stdin);
     //  freopen("out.txt","w",stdout);
        int x,y,z;
        int n;
        int m;
        int T;
        scanf("%d",&T);
        int iCase=0;
        while(T--)
        {
            iCase++;
            scanf("%d%d",&n,&m);
            Build(1,1,n);
            while(m--)
            {
                scanf("%d%d%d",&x,&y,&z);
                update(1,x,y,z);
            }
            printf("Case %d: The total value of the hook is %d.\n",iCase,segTree[1].sum);
        }
        return 0;
    }
  • 相关阅读:
    yum 源配置
    RHCE学习笔记 管理1 (第六章 第七章)
    阿里云ecs(phpstudy一件包)
    PHP第三方登录 -- 微博登录
    php 实现qq第三方登录
    Linux 搭建svn服务器
    Linux vi编辑器的基本命令
    Mysql 导出导入
    svn服务配置和日常维护命令
    Eclipse导入idea 项目
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2639390.html
Copyright © 2020-2023  润新知