• POJ 1068 Parencodings(模拟)


    Parencodings
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 15075   Accepted: 8989

    Description

    Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
    q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
    q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

    Following is an example of the above encodings:

    S (((()()())))
    P-sequence 4 5 6666
    W-sequence 1 1 1456

    Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

    Input

    The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

    Output

    The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

    Sample Input

    2
    6
    4 5 6 6 6 6
    9 
    4 6 6 6 6 8 9 9 9
    

    Sample Output

    1 1 1 4 5 6
    1 1 2 4 5 1 1 3 9

    Source

     
     
     
    /*
    POJ 1068 Parencodings
    简单模拟
    用数组a[i]表示第i个右括号和第i+1个右括号间的左括号数
    然后逐渐找和右括号匹配的左括号所处的位置
    i-j
    
    */
    
    
    #include<stdio.h>
    #include<iostream>
    
    const int MAXN=50;
    int P[MAXN];
    int W[MAXN];
    int a[MAXN];
    
    int main()
    {
        int T;
        int n;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d",&n);
            for(int i=1;i<=n;i++)
               scanf("%d",&P[i]);
            a[0]=P[1];
            for(int i=1;i<n;i++) a[i]=P[i+1]-P[i];
            int j;
            for(int i=1;i<=n;i++)
            {
                for(j=i-1;j>=0;j--)//匹配该右括号
                {
                    if(a[j]>0)
                    {
                        a[j]--;
                        break;
                    }
                }
                W[i]=i-j;
            }
            for(int i=1;i<n;i++)printf("%d ",W[i]);
            printf("%d\n",W[n]);
        }
        return 0;
    }
  • 相关阅读:
    5月9日黑马java之java中四种权限修饰符
    MOOCjava之输入输出
    5月7日黑马java之final关键字的用法
    MOOCjava之数据库基础
    MOOCjava之线程
    毕业设计
    shiro 权限
    Spring Boot Thymeleaf
    Spring Boot文件处理
    Spring Boot Rest模板
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2636171.html
Copyright © 2020-2023  润新知