• POJ 3264 Balanced Lineup(线段树)


    Balanced Lineup
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 23699   Accepted: 11019
    Case Time Limit: 2000MS

    Description

    For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

    Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

    Input

    Line 1: Two space-separated integers, N and Q.
    Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
    Lines N+2..N+Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

    Output

    Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

    Sample Input

    6 3
    1
    7
    3
    4
    2
    5
    1 5
    4 6
    2 2

    Sample Output

    6
    3
    0

    Source

     
     
     
    这题早就做过了。。。
    重新做一次,认真学一下线段树吧!
    /*
    POJ 3264 Balanced Lineup
    线段树
    求区间中最大数和最小数的差
    */
    #include<stdio.h>
    #include<algorithm>
    #include<iostream>
    using namespace std;
    const int MAXN=50010;
    const int INF=0x3fffffff;
    int nMax,nMin;
    struct Node
    {
        int l,r;
        int nMin,nMax;
    }segTree[3*MAXN];
    void Build(int i,int l,int r)
    {
        segTree[i].l=l;
        segTree[i].r=r;
        if(l==r)
        {
            scanf("%d",&segTree[i].nMin);
            segTree[i].nMax=segTree[i].nMin;
            return;
        }
        int mid=((l+r)>>1);
        Build(i<<1,l,mid);
        Build((i<<1)|1,mid+1,r);
        segTree[i].nMin=min(segTree[i<<1].nMin,segTree[(i<<1)|1].nMin);
        segTree[i].nMax=max(segTree[i<<1].nMax,segTree[(i<<1)|1].nMax);
    }
    void Query(int i,int l,int r)
    {
        if(segTree[i].nMax<=nMax&&segTree[i].nMin>=nMin)return;
        if(segTree[i].l==l&&segTree[i].r==r)
        {
            nMin=min(segTree[i].nMin,nMin);
            nMax=max(segTree[i].nMax,nMax);
            return;
        }
        int mid=(segTree[i].l+segTree[i].r)>>1;
        if(r<=mid)Query(i<<1,l,r);
        else if(l>mid)Query((i<<1)|1,l,r);
        else
        {
            Query(i<<1,l,mid);
            Query((i<<1)|1,mid+1,r);
        }
    }
    int main()
    {
        int n,q;
        int l,r;
        while(scanf("%d%d",&n,&q)!=EOF)
        {
            Build(1,1,n);
            while(q--)
            {
                scanf("%d%d",&l,&r);
                nMax=-INF;
                nMin=INF;
                Query(1,l,r);
                printf("%d\n",nMax-nMin);
            }
        }
        return 0;
    }
  • 相关阅读:
    【Java】REST风格
    KMP(烤馍片)算法
    Lca求法 (树链剖分 与 倍增)
    hash学习笔记
    星际网络(数学)
    P3537 [POI2012]SZA-Cloakroom (背包)
    乘车路线 (二维最短路)
    渔民的烦恼 (二分)
    Jmeter 常用函数(18)- 详解 __isDefined
    Jmeter 常用函数(17)- 详解 __substring
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2631659.html
Copyright © 2020-2023  润新知