• POJ 2352 Stars(树状数组)


    Stars
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 22464   Accepted: 9787

    Description

    Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

    For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

    You are to write a program that will count the amounts of the stars of each level on a given map.

    Input

    The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

    Output

    The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

    Sample Input

    5
    1 1
    5 1
    7 1
    3 3
    5 5

    Sample Output

    1
    2
    1
    1
    0

    Hint

    This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

    Source

     
     
     
    可以用线段数做,也可以用树状数组。
    还是感觉树状数组比较简单一些。
     
    /*
    POJ 2352 Stars
    就是求每个小星星左小角的星星的个数。坐标按照Y升序,Y相同X升序的顺序给出
    由于y轴已经排好序,可以按照x坐标建立一维树状数组
    */
    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    using namespace std;
    const int MAXN=15010;
    const int MAXX=32010;
    int c[MAXX];//树状数组的c数组
    int cnt[MAXN];//统计结果
    int lowbit(int x)
    {
        return x&(-x);
    }
    void add(int i,int val)
    {
        while(i<=MAXX)
        {
            c[i]+=val;
            i+=lowbit(i);
        }
    }
    int sum(int i)
    {
        int s=0;
        while(i>0)
        {
            s+=c[i];
            i-=lowbit(i);
        }
        return s;
    }
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
        int n;
        int x,y;
        while(scanf("%d",&n)!=EOF)
        {
            memset(c,0,sizeof(c));
            memset(cnt,0,sizeof(cnt));
            for(int i=0;i<n;i++)
            {
                scanf("%d%d",&x,&y);
                //加入x+1,是为了避免0,X是可能为0的
                int temp=sum(x+1);
                cnt[temp]++;
                add(x+1,1);
    
            }
            for(int i=0;i<n;i++)
             printf("%d\n",cnt[i]);
        }
        return 0;
    }
  • 相关阅读:
    FastAPI(38)- 模拟一个跨域场景
    FastAPI(37)- Middleware 中间件
    Python
    Python
    FastAPI(35)- 依赖项中使用 yield + Context Manager 上下文管理器
    汇编 | CPU物理地址本质理解
    汇编 | DosBox初步接触的一些初始化设置(窗口大小 & 默认命令)
    汇编语言 第3版 王爽 检测点答案及详细解析 (更新中)
    JSP | Tomcat目录结构详解
    JSP常见错误以及解决方案
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2630072.html
Copyright © 2020-2023  润新知