• HDU 1033 Edge (水题)


    Edge

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 886    Accepted Submission(s): 576


    Problem Description
    For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.
    After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.
     
    Input
    The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.
     
    Output
    For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command "300 420 moveto". The first turn occurs at (310, 420) using the command "310 420 lineto". Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.

    You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.

     
    Sample Input
    V AVV
     
    Sample Output
    300 420 moveto 310 420 lineto 310 430 lineto stroke showpage 300 420 moveto 310 420 lineto 310 410 lineto 320 410 lineto 320 420 lineto stroke showpage
     
    Source
     
     
     
     
    纠结的水题。。。。。题目完全不知道再说什么。。。
    唉。。。。这个题意坑爹啊。。。。
     
    其实就是个水模拟,水题。
     
    A是右转,V是左转。。。。初始坐标是300,420,每次走10。。。。。。模拟就可以了,四个走向
     
     
    #include<stdio.h>
    #include<string.h>
    const int MAXN=200;
    char str[MAXN];
    int main()
    {
        int x,y;
        while(scanf("%s",&str)!=EOF)
        {
            int len=strlen(str);
            int x=310,y=420;
            int p=1;//标记走向,一开始是X轴正方向
            printf("300 420 moveto\n310 420 lineto\n");
            for(int i=0;i<len;i++)
            {
                switch(p)
                {
                    case 1://X轴正方向
                         if(str[i]=='V') p=2,y+=10;
                         else p=-2,y-=10;
                         break;
                    case 2://Y轴正方向
                         if(str[i]=='V') p=-1,x-=10;
                         else p=1,x+=10;
                         break;
                    case -1://X轴负方向
                         if(str[i]=='V') p=-2,y-=10;
                         else p=2,y+=10;
                         break; 
                    case -2:
                         if(str[i]=='V') p=1,x+=10;
                         else p=-1,x-=10;
                         break;
                }    
                printf("%d %d lineto\n",x,y);
            }    
            printf("stroke\nshowpage\n");
     
        }    
        return 0;
        
    }    
  • 相关阅读:
    47c# 新建线程Thread,线程内与操作窗体控件
    48Command line is too long. Shorten command line for Test or also for
    MySQL 基础
    MySQL 的 GRANT和REVOKE 命令
    Linux 配置免密登录
    本地多个rdb文件,导入自建redis
    自建codis上阿里云
    Windows删除指定目录下的3天前的文件
    VS2017:提示“Error MSB8020 The build tools for v142 (Platform Toolset = 'v142') cannot be found. 。。。。”错误解决办法
    根据文件File,返回名称excel名称管理器对应的行和列
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2532450.html
Copyright © 2020-2023  润新知