• HDU 1155 Bungee Jumping(简单的物理题)


    Bungee Jumping

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 419    Accepted Submission(s): 189


    Problem Description
    Once again, James Bond is fleeing from some evil people who want to see him dead. Fortunately, he has left a bungee rope on a nearby highway bridge which he can use to escape from his enemies. His plan is to attach one end of the rope to the bridge, the other end of the rope to his body and jump off the bridge. At the moment he reaches the ground, he will cut the rope, jump into his car and be gone.

    Unfortunately, he had not had enough time to calculate whether the bungee rope has the right length, so it is not clear at all what is going to happen when he jumps off the bridge. There are three possible scenarios:
    The rope is too short (or too strong), and James Bond will never reach the ground.
    The rope is too long (or too weak), and James Bond will be going too fast when he touches the ground. Even for a special agent, this can be very dangerous. You may assume that if he collides at a speed of more than 10 m/s, he will not survive the impact.
    The rope's length and strength are good. James Bond touches the ground at a comfortable speed and can escape.
    As his employer, you would like to know whether James Bond survives or whether you should place a job ad for the soon-to-be vacant position in the local newspaper. Your physicists claim that:
    The force with which James is pulled towards the earth is
    9.81 * w,
    where w is his weight in kilograms and 9.81 is the Earth acceleration in meters over squared seconds.
    Mr. Bond falls freely until the rope tautens. Then the force with which the bungee rope pulls him back into the sky depends on the current length of the rope and is
    k * Δl,
    where Δl is the difference between the rope's current length and its nominal, unexpanded length, and k is a rope-specific constant.
    Given the rope's strength k, the nominal length of the rope l in meters, the height of the bridge s in meters, and James Bond's body weight w, you have to determine what is going to happen to our hero. For all your calculations, you may assume that James Bond is a point at the end of the rope and the rope has no mass. You may further assume that k, l, s, and w are non-negative and that s < 200.

    The input contains several test cases, one test case per line. Each test case consists of four floating-point numbers (k, l, s, and w) that describe the situation. Depending on what is going to happen, your program must print "Stuck in the air.", "Killed by the impact.", or "James Bond survives.". Input is terminated by a line containing four 0s, this line should not be processed.
     
    Sample Input
    350 20 30 75 375 20 30 75 400 20 30 75 425 20 30 75 450 20 30 75 400 20 30 50 400 20 30 80 400 20 30 85 0 0 0 0
     
    Sample Output
    Killed by the impact. James Bond survives. James Bond survives. James Bond survives. Stuck in the air. Stuck in the air. James Bond survives. Killed by the impact.
     
    Source
     
    Recommend
    Eddy
     
     
     
     
     
     
    用的动能定理~~~~~~~
     
    Ep=mgh,Ek=k*x*x/2;
     
    #include<stdio.h>
    #include<math.h>
    const double G=9.81;
    int main()
    {
        double k,l,s,w;
        while(scanf("%lf%lf%lf%lf",&k,&l,&s,&w))
        {
            if(k==0&&l==0&&s==0&&w==0)break;
            double e=w*G*s;
            if(s>l)e-=k*(s-l)*(s-l)/2;
            if(e<0)
            {
                printf("Stuck in the air.\n");
                continue;
            }    
            double v=sqrt(e*2/w);
            if(v>10) printf("Killed by the impact.\n");
            else printf("James Bond survives.\n");
        }    
        return 0;
    }    
  • 相关阅读:
    技术干货 | 闲鱼:一个优秀的 Push 平台,需要经历怎样的前世今生
    钉钉宜搭3.0发布!易连接、酷数据、更安全
    聚焦2021云栖大会,边缘云专场畅谈技术应用创新
    基层数字化治理困境如何破局?
    2021年阿里云双11上云狂欢节亿元加油包提前领攻略
    形式化验证工具TLA+:程序员视角的入门之道
    ArrayList源码浅析
    对云信SDK的研究
    写在当下
    Delphi 正则表达式起步
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2519805.html
Copyright © 2020-2023  润新知