• HDU 4185 Oil Skimming(二分匹配,匈牙利算法)


    Oil Skimming

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 87    Accepted Submission(s): 50


    Problem Description
    Thanks to a certain "green" resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water's surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.
     
    Input
    The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of '#' represents an oily cell, and a character of '.' represents a pure water cell.
     
    Output
    For each case, one line should be produced, formatted exactly as follows: "Case X: M" where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.
     
    Sample Input
    1 6 ...... .##... .##... ....#. ....## ......
     
    Sample Output
    Case 1: 3
     
    Source
     
    Recommend
    lcy
     
     
    简单的二分匹配,用匈牙利算法。模版题。。
    #include<stdio.h>
    #include<string.h>
    const int MAXN=1000;
    char map[610][610];
    int tt[610][610];
    int uN,vN;  //u,v数目
    int g[MAXN][MAXN];
    int linker[MAXN];
    bool used[MAXN];
    bool dfs(int u)
    {
        int v;
        for(v=0;v<vN;v++)
            if(g[u][v]&&!used[v])
            {
                used[v]=true;
                if(linker[v]==-1||dfs(linker[v]))
                {
                    linker[v]=u;
                    return true;
                }    
            }  
        return false;  
    }    
    int hungary()
    {
        int res=0;
        int u;
        memset(linker,-1,sizeof(linker));
        for(u=0;u<uN;u++)
        {
            memset(used,0,sizeof(used));
            if(dfs(u))  res++;
        } 
        return res;   
    }  
    
    int main()
    {
        int T;
        int n;
        scanf("%d",&T);
        int iCase=0;
        int tmp;
        while(T--)
        {
            iCase++;
            scanf("%d",&n);
           
            tmp=0;
            for(int i=0;i<n;i++)
            {
              scanf("%s",&map[i]);
              for(int j=0;j<n;j++)
               if(map[i][j]=='#') tt[i][j]=tmp++;
            }    
            memset(g,0,sizeof(g));
            uN=vN=tmp;
            for(int i=0;i<n;i++)
              for(int j=0;j<n;j++)
              {
                  if(map[i][j]!='#') continue;
                  if(i>0&&map[i-1][j]=='#') g[tt[i][j]][tt[i-1][j]]=1;
                  if(i<n-1&&map[i+1][j]=='#') g[tt[i][j]][tt[i+1][j]]=1;
                  if(j>0&&map[i][j-1]=='#') g[tt[i][j]][tt[i][j-1]]=1;
                  if(j<n-1&&map[i][j+1]=='#') g[tt[i][j]][tt[i][j+1]]=1;
              }     
            
            int res=hungary();
            printf("Case %d: %d\n",iCase,res/2);
        }    
        return 0;
    }    
  • 相关阅读:
    Javascript高性能编程-提高Dom访问速度
    获取在线人数
    js倒计时
    支付宝支付
    微信扫码支付
    多条sql语句实现事物处理
    防止页面重复刷新
    bootstrapTable.js 使用
    org_chart.js 使用方法
    js上传图片及时显示
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2465315.html
Copyright © 2020-2023  润新知