• HDU 1015 Safecracker (枚举)


    Safecracker

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3713    Accepted Submission(s): 1919


    Problem Description
    === Op tech briefing, 2002/11/02 06:42 CST ===
    "The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."

    v - w^2 + x^3 - y^4 + z^5 = target

    "For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then."

    === Op tech directive, computer division, 2002/11/02 12:30 CST ===

    "Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below."
     
    Sample Input
    1 ABCDEFGHIJKL 11700519 ZAYEXIWOVU 3072997 SOUGHT 1234567 THEQUICKFROG 0 END
     
    Sample Output
    LKEBA YOXUZ GHOST no solution
     
    Source
     
    Recommend
    JGShining
     
     
    比较暴力,直接枚举的
    5重循环。
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    #include<iostream>
    using namespace std;
    char str[25];
    bool cmp(char a,char b)
    {
    return a>b;
    }
    int main()
    {
    int target;
    int a,b,c,d,e;
    int ta,tb,tc,td,te;
    int flag;
    while(scanf("%d %s",&target,&str))
    {
    if(target==0) break;
    int len= strlen(str);
    flag=0;
    sort(str,str+len,cmp);
    for(a=0;a<len;a++)
    {
    for(b=0;b<len;b++)
    {
    if(b==a) continue;
    for(c=0;c<len;c++)
    {
    if(c==b||c==a) continue;
    for(d=0;d<len;d++)
    {
    if(d==a||d==b||d==c) continue;
    for(e=0;e<len;e++)
    {
    if(e==a||e==b||e==c||e==d) continue;
    ta=str[a]-'A'+1;
    tb=str[b]-'A'+1;
    tc=str[c]-'A'+1;
    td=str[d]-'A'+1;
    te=str[e]-'A'+1;
    if(ta-tb*tb+tc*tc*tc-td*td*td*td+te*te*te*te*te==target)
    {
    flag=1;

    printf("%c%c%c%c%c\n",str[a],str[b],str[c],str[d],str[e]);
    break;
    }

    }
    if(flag) break;
    }
    if(flag) break;
    }
    if(flag) break;
    }
    if(flag) break;
    }

    if(flag==0)printf("no solution\n");

    }
    return 0;
    }
  • 相关阅读:
    SysUtils.UpperCase、SysUtils.LowerCase 大小写转换
    Sql Server 2005 数据库备份还原后出现“受限制用户”问题的解决
    为什么要跪谢
    【基础】C#卸载快捷方式添加
    DataTable 复制 DataRow 出现 “该行已经属于另一个表”错误的解决办法
    将int型转化成五位字符串,前面用0填充
    C#嵌套类的使用方法及特性(转)
    net内存回收与Dispose﹐Close﹐Finalize方法(转)
    sqlhelper中文注释版(转)
    windows2003消息队列的安装
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2410371.html
Copyright © 2020-2023  润新知